net/bird: update to version 1.2.5
authorAlexandros C. Couloumbis <alex@ozo.com>
Tue, 26 Oct 2010 11:55:34 +0000 (11:55 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 8 Oct 2013 19:16:09 +0000 (19:16 +0000)
git-svn-id: svn+ssh://svn.openwrt.org/openwrt/packages@23638 3c298f89-4303-0410-b956-a3cf2f4a3e73

net/bird/Makefile
net/bird/patches/0002-ula_ipv6.patch [deleted file]

index f18f7deff157d2bc0d65755f12841f7b32e0460a..b080d6555e3b9e34819e15d4223c5ac459a8fa3a 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=bird
-PKG_VERSION:=1.2.4
+PKG_VERSION:=1.2.5
 PKG_RELEASE:=1
 
 PKG_SOURCE:=bird-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=ftp://bird.network.cz/pub/bird
-PKG_MD5SUM:=8db90b12200ebb20f5aa93a2de9937c6
+PKG_MD5SUM:=06f330da3290018335d0761549d90226
 PKG_BUILD_DEPENDS:=libncurses libreadline
 
 include $(INCLUDE_DIR)/package.mk
diff --git a/net/bird/patches/0002-ula_ipv6.patch b/net/bird/patches/0002-ula_ipv6.patch
deleted file mode 100644 (file)
index a9fc6c9..0000000
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/lib/ipv6.c
-+++ b/lib/ipv6.c
-@@ -73,6 +73,8 @@ ipv6_classify(ip_addr *a)
-     return IADDR_HOST | SCOPE_LINK;
-   if ((x & 0xffc00000) == 0xfec00000)         /* Site-Local Address */
-     return IADDR_HOST | SCOPE_SITE;
-+  if ((x & 0xfe000000) == 0xfc000000)         /* Unique Local Unicast Address (RFC 4193) */
-+    return IADDR_HOST | SCOPE_SITE;
-   if ((x & 0xff000000) == 0xff000000)         /* Multicast Address */
-     {
-       unsigned int scope = (x >> 16) & 0x0f;