bmx7: use configReaload on service reload 364/head
authorPaul Spooren <spooren@informatik.uni-leipzig.de>
Tue, 24 Apr 2018 04:16:50 +0000 (13:16 +0900)
committerPaul Spooren <spooren@informatik.uni-leipzig.de>
Wed, 25 Apr 2018 06:48:43 +0000 (15:48 +0900)
It's #363 for procdbmx7: use configReaload on service reload

Signed-off-by: Paul Spooren <spooren@informatik.uni-leipzig.de>
bmx7/Makefile
bmx7/files/etc/init.d/bmx7

index b2d07ab94a6ca75e36f913a6dbbbbadb6bb7a7e2..612fb55f9506cffaeff3068fd506448929164539 100644 (file)
@@ -33,7 +33,7 @@ PKG_SOURCE_URL:=git://github.com/bmx-routing/bmx7.git
 PKG_REV:=f78db8298dd8b3658f6fcfa90df2644a15b99924
 PKG_MIRROR_HASH:=80ca8e04603d824e4dede0055030c765bd9e69f7945c01ffb953de37b228028e
 PKG_VERSION:=r2018030903
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 PKG_LICENSE:=GPL-2.0
 
 PKG_SOURCE_VERSION:=$(PKG_REV)
index d8f1939906db919a9e013f103a49ad2f08f01037..515dc8876df77b7aca966c7f30dc117381c7f1cd 100755 (executable)
@@ -18,3 +18,7 @@ start_service() {
        procd_set_param respawn
        procd_close_instance
 }
+
+reload_service() {
+    $BIN -c configReload
+}