baresip + restund: delete faulty patch
authorSebastian Kemper <sebastian_ml@gmx.net>
Tue, 26 Dec 2017 13:26:45 +0000 (14:26 +0100)
committerSebastian Kemper <sebastian_ml@gmx.net>
Tue, 26 Dec 2017 13:27:01 +0000 (14:27 +0100)
The patch is wrong. It may cause errors of the "illegal instruction" variety.
The libre package fix in commit e40f0ea06fe7433eff71c4561a4776f068e97bc7 makes
this patch unnecessary anyway. Drop it.

Signed-off-by: Sebastian Kemper <sebastian_ml@gmx.net>
net/baresip/Makefile
net/baresip/patches/001-fix-linker-call.patch [deleted file]
net/restund/Makefile
net/restund/patches/001-fix-linker-call.patch [deleted file]

index 958f12471edd88b0d9bc7bbb9b457a35227b01ea..b23827141f2bcb853efa23e37e230e860bd8bbe3 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=baresip
 PKG_VERSION:=0.5.6
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub
diff --git a/net/baresip/patches/001-fix-linker-call.patch b/net/baresip/patches/001-fix-linker-call.patch
deleted file mode 100644 (file)
index 0df5ced..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -199,9 +199,9 @@ libbaresip.pc:
- $(BIN):       $(APP_OBJS)
-       @echo "  LD      $@"
- ifneq ($(GPROF),)
--      $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
-+      $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
- else
--      $(HIDE)$(LD) $(LFLAGS) $(APP_LFLAGS) $^ \
-+      $(HIDE)$(LD) $(LFLAGS) $(SH_LFLAGS) $(APP_LFLAGS) $^ \
-               -L$(LIBRE_SO) -lre $(LIBS) -o $@
- endif
index 21c956e4308c7c1e214189b3a6c1a3d3cefec80a..6206be4193dc64425f0855f893747a53617a3105 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=restund
 PKG_VERSION:=0.4.12
-PKG_RELEASE:=4
+PKG_RELEASE:=5
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://www.creytiv.com/pub
diff --git a/net/restund/patches/001-fix-linker-call.patch b/net/restund/patches/001-fix-linker-call.patch
deleted file mode 100644 (file)
index abae86c..0000000
+++ /dev/null
@@ -1,14 +0,0 @@
---- a/Makefile
-+++ b/Makefile
-@@ -99,9 +99,9 @@ all: $(MOD_BINS) $(BIN)
- $(BIN): $(OBJS)
-       @echo "  LD      $@"
- ifneq ($(GPROF),)
--      @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
-+      @$(LD) $(LFLAGS) $(SH_LFLAGS) $(APP_LFLAGS) $^ ../re/libre.a $(LIBS) -o $@
- else
--      @$(LD) $(LFLAGS) $(APP_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
-+      @$(LD) $(LFLAGS) $(SH_LFLAGS) $(APP_LFLAGS) $^ -L$(LIBRE_SO) -lre $(LIBS) -o $@
- endif
- $(BUILD)/%.o: %.c $(BUILD) Makefile $(APP_MK)