busybox: update to 1.33.1
[openwrt/openwrt.git] / include / prereq-build.mk
1 # SPDX-License-Identifier: GPL-2.0-only
2 #
3 # Copyright (C) 2006-2020 OpenWrt.org
4
5 include $(TOPDIR)/rules.mk
6 include $(INCLUDE_DIR)/prereq.mk
7
8 SHELL:=sh
9 PKG_NAME:=Build dependency
10
11
12 # Required for the toolchain
13 $(eval $(call TestHostCommand,working-make, \
14 Please install GNU make v4.1 or later., \
15 $(MAKE) -v | grep -E 'Make (4\.[1-9]|[5-9]\.)'))
16
17 $(eval $(call TestHostCommand,case-sensitive-fs, \
18 OpenWrt can only be built on a case-sensitive filesystem, \
19 rm -f $(TMP_DIR)/test.*; touch $(TMP_DIR)/test.fs; \
20 test ! -f $(TMP_DIR)/test.FS))
21
22 $(eval $(call TestHostCommand,proper-umask, \
23 Please build with umask 022 - other values produce broken packages, \
24 umask | grep -xE 0?0[012][012]))
25
26 ifndef IB
27 $(eval $(call SetupHostCommand,gcc, \
28 Please install the GNU C Compiler (gcc) 6 or later, \
29 $(CC) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
30 gcc -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
31 gcc --version | grep -E 'Apple.(LLVM|clang)' ))
32
33 $(eval $(call TestHostCommand,working-gcc, \
34 \nPlease reinstall the GNU C Compiler (6 or later) - \
35 it appears to be broken, \
36 echo 'int main(int argc, char **argv) { return 0; }' | \
37 gcc -x c -o $(TMP_DIR)/a.out -))
38
39 $(eval $(call SetupHostCommand,g++, \
40 Please install the GNU C++ Compiler (g++) 6 or later, \
41 $(CXX) -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
42 g++ -dumpversion | grep -E '^([6-9]\.?|1[0-9]\.?)', \
43 g++ --version | grep -E 'Apple.(LLVM|clang)' ))
44
45 $(eval $(call TestHostCommand,working-g++, \
46 \nPlease reinstall the GNU C++ Compiler (4.8 or later) - \
47 it appears to be broken, \
48 echo 'int main(int argc, char **argv) { return 0; }' | \
49 g++ -x c++ -o $(TMP_DIR)/a.out - -lstdc++ && \
50 $(TMP_DIR)/a.out))
51
52 $(eval $(call TestHostCommand,ncurses, \
53 Please install ncurses. (Missing libncurses.so or ncurses.h), \
54 echo 'int main(int argc, char **argv) { initscr(); return 0; }' | \
55 gcc -include ncurses.h -x c -o $(TMP_DIR)/a.out - -lncurses))
56 endif # IB
57
58 ifeq ($(HOST_OS),Linux)
59 zlib_link_flags := -Wl,-Bstatic -lz -Wl,-Bdynamic
60 else
61 zlib_link_flags := -lz
62 endif
63
64 $(eval $(call TestHostCommand,perl-data-dumper, \
65 Please install the Perl Data::Dumper module, \
66 perl -MData::Dumper -e 1))
67
68 $(eval $(call TestHostCommand,perl-findbin, \
69 Please install the Perl FindBin module, \
70 perl -MFindBin -e 1))
71
72 $(eval $(call TestHostCommand,perl-file-copy, \
73 Please install the Perl File::Copy module, \
74 perl -MFile::Copy -e 1))
75
76 $(eval $(call TestHostCommand,perl-file-compare, \
77 Please install the Perl File::Compare module, \
78 perl -MFile::Compare -e 1))
79
80 $(eval $(call TestHostCommand,perl-thread-queue, \
81 Please install the Perl Thread::Queue module, \
82 perl -MThread::Queue -e 1))
83
84 $(eval $(call SetupHostCommand,tar,Please install GNU 'tar', \
85 gtar --version 2>&1 | grep GNU, \
86 gnutar --version 2>&1 | grep GNU, \
87 tar --version 2>&1 | grep GNU))
88
89 $(eval $(call SetupHostCommand,find,Please install GNU 'find', \
90 gfind --version 2>&1 | grep GNU, \
91 find --version 2>&1 | grep GNU))
92
93 $(eval $(call SetupHostCommand,bash,Please install GNU 'bash', \
94 bash --version 2>&1 | grep GNU))
95
96 $(eval $(call SetupHostCommand,xargs, \
97 Please install 'xargs' that supports '-r/--no-run-if-empty', \
98 gxargs -r --version, \
99 xargs -r --version))
100
101 $(eval $(call SetupHostCommand,patch,Please install GNU 'patch', \
102 gpatch --version 2>&1 | grep 'Free Software Foundation', \
103 patch --version 2>&1 | grep 'Free Software Foundation'))
104
105 $(eval $(call SetupHostCommand,diff,Please install diffutils, \
106 gdiff --version 2>&1 | grep diff, \
107 diff --version 2>&1 | grep diff))
108
109 $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
110 gcp --help 2>&1 | grep 'Copy SOURCE', \
111 cp --help 2>&1 | grep 'Copy SOURCE'))
112
113 $(eval $(call SetupHostCommand,seq,Please install seq, \
114 gseq --version, \
115 seq --version 2>&1 | grep seq))
116
117 $(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
118 gawk --version 2>&1 | grep GNU, \
119 awk --version 2>&1 | grep GNU))
120
121 $(eval $(call SetupHostCommand,grep,Please install GNU 'grep', \
122 ggrep --version 2>&1 | grep GNU, \
123 grep --version 2>&1 | grep GNU))
124
125 $(eval $(call SetupHostCommand,egrep,Please install GNU 'grep', \
126 gegrep --version 2>&1 | grep GNU, \
127 egrep --version 2>&1 | grep GNU))
128
129 $(eval $(call SetupHostCommand,getopt, \
130 Please install an extended getopt version that supports --long, \
131 gnugetopt -o t --long test -- --test | grep '^ *--test *--', \
132 getopt -o t --long test -- --test | grep '^ *--test *--', \
133 /usr/local/opt/gnu-getopt/bin/getopt -o t --long test -- --test | grep '^ *--test *--'))
134
135 $(eval $(call SetupHostCommand,stat,Cannot find a file stat utility, \
136 gnustat -c%s $(TOPDIR)/Makefile, \
137 gstat -c%s $(TOPDIR)/Makefile, \
138 stat -c%s $(TOPDIR)/Makefile))
139
140 $(eval $(call SetupHostCommand,unzip,Please install 'unzip', \
141 unzip 2>&1 | grep zipfile, \
142 unzip))
143
144 $(eval $(call SetupHostCommand,bzip2,Please install 'bzip2', \
145 bzip2 --version </dev/null))
146
147 $(eval $(call SetupHostCommand,wget,Please install GNU 'wget', \
148 wget --version | grep GNU))
149
150 $(eval $(call SetupHostCommand,install,Please install GNU 'install', \
151 install --version | grep GNU, \
152 ginstall --version | grep GNU))
153
154 $(eval $(call SetupHostCommand,perl,Please install Perl 5.x, \
155 perl --version | grep "perl.*v5"))
156
157 $(eval $(call CleanupPython2))
158
159 $(eval $(call SetupHostCommand,python,Please install Python >= 3.6, \
160 python3.9 -V 2>&1 | grep 'Python 3', \
161 python3.8 -V 2>&1 | grep 'Python 3', \
162 python3.7 -V 2>&1 | grep 'Python 3', \
163 python3.6 -V 2>&1 | grep 'Python 3', \
164 python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
165
166 $(eval $(call SetupHostCommand,python3,Please install Python >= 3.6, \
167 python3.9 -V 2>&1 | grep 'Python 3', \
168 python3.8 -V 2>&1 | grep 'Python 3', \
169 python3.7 -V 2>&1 | grep 'Python 3', \
170 python3.6 -V 2>&1 | grep 'Python 3', \
171 python3 -V 2>&1 | grep -E 'Python 3\.[6-9]\.?'))
172
173 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
174 git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
175
176 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
177 file --version 2>&1 | grep file))
178
179 $(eval $(call SetupHostCommand,rsync,Please install 'rsync', \
180 rsync --version </dev/null))
181
182 $(eval $(call SetupHostCommand,which,Please install 'which', \
183 which which | grep which))
184
185 $(STAGING_DIR_HOST)/bin/mkhash: $(SCRIPT_DIR)/mkhash.c
186 mkdir -p $(dir $@)
187 $(CC) -O2 -I$(TOPDIR)/tools/include -o $@ $<
188
189 prereq: $(STAGING_DIR_HOST)/bin/mkhash
190
191 # Install ldconfig stub
192 $(eval $(call TestHostCommand,ldconfig-stub,Failed to install stub, \
193 touch $(STAGING_DIR_HOST)/bin/ldconfig && \
194 chmod +x $(STAGING_DIR_HOST)/bin/ldconfig))