kernel patch: remove pcmcia compatibility crap - doesn't run on freebsd
[openwrt/openwrt.git] / openwrt / target / linux / generic-2.4 / patches / 051-remove_pcmcia_modinst_compat.patch
1 --- linux.old/Makefile Tue Oct 10 22:24:41 2006
2 +++ linux.dev/Makefile Tue Oct 10 22:26:19 2006
3 @@ -427,17 +427,8 @@
4 depmod_opts := -b $(INSTALL_MOD_PATH) -r
5 endif
6 .PHONY: _modinst_post
7 -_modinst_post: _modinst_post_pcmcia
8 +_modinst_post:
9 if [ -r System.map ]; then $(DEPMOD) -ae -F System.map $(depmod_opts) $(KERNELRELEASE); fi
10 -
11 -# Backwards compatibilty symlinks for people still using old versions
12 -# of pcmcia-cs with hard coded pathnames on insmod. Remove
13 -# _modinst_post_pcmcia for kernel 2.4.1.
14 -.PHONY: _modinst_post_pcmcia
15 -_modinst_post_pcmcia:
16 - cd $(MODLIB); \
17 - mkdir -p pcmcia; \
18 - find kernel -path '*/pcmcia/*' -name '*.o' | xargs -i -r ln -sf ../{} pcmcia
19
20 .PHONY: $(patsubst %, _modinst_%, $(SUBDIRS))
21 $(patsubst %, _modinst_%, $(SUBDIRS)) :