kernel: remove linux 4.4 support
[openwrt/openwrt.git] / package / devel / perf / musl-include / string.h
1 #ifndef __MUSL_COMPAT_STRING_H
2 #define __MUSL_COMPAT_STRING_H
3
4 #include_next <string.h>
5
6 /* Change XSI compliant version into GNU extension hackery */
7 static inline char *
8 gnu_strerror_r(int err, char *buf, size_t buflen)
9 {
10 if (strerror_r(err, buf, buflen))
11 return NULL;
12 return buf;
13 }
14 #ifdef _GNU_SOURCE
15 #define strerror_r gnu_strerror_r
16 #endif
17
18 #endif