hostapd: update to latest git, remove openssl dependency for hostapd-full, it works...
[openwrt/openwrt.git] / package / hostapd / patches / 120-nl80211_ap_fix.patch
1 --- a/src/drivers/driver_nl80211.c
2 +++ b/src/drivers/driver_nl80211.c
3 @@ -4418,10 +4418,10 @@ static void *i802_init(struct hostapd_da
4 /* start listening for EAPOL on the default AP interface */
5 add_ifidx(drv, drv->ifindex);
6
7 - if (params->bssid) {
8 - if (hostapd_set_iface_flags(drv, drv->ifname, 0))
9 - goto failed;
10 + if (hostapd_set_iface_flags(drv, drv->ifname, 0))
11 + goto failed;
12
13 + if (params->bssid) {
14 if (set_ifhwaddr(drv, drv->ifname, params->bssid))
15 goto failed;
16 }