openvpn: update to 2.3.11
[openwrt/openwrt.git] / package / network / services / openvpn / patches / 100-polarssl-disable-runtime-version-check.patch
1 --- a/src/openvpn/ssl_polarssl.c
2 +++ b/src/openvpn/ssl_polarssl.c
3 @@ -1151,7 +1151,7 @@ const char *
4 get_ssl_library_version(void)
5 {
6 static char polar_version[30];
7 - unsigned int pv = version_get_number();
8 + unsigned int pv = POLARSSL_VERSION_NUMBER;
9 sprintf( polar_version, "PolarSSL %d.%d.%d",
10 (pv>>24)&0xff, (pv>>16)&0xff, (pv>>8)&0xff );
11 return polar_version;