tools: gmp: Update to 6.1.2
[openwrt/openwrt.git] / package / network / utils / curl / patches / 310-polarssl-disable-runtime-version-check.patch
1 --- a/lib/vtls/polarssl.c
2 +++ b/lib/vtls/polarssl.c
3 @@ -657,7 +657,7 @@ void Curl_polarssl_session_free(void *pt
4
5 size_t Curl_polarssl_version(char *buffer, size_t size)
6 {
7 - unsigned int version = version_get_number();
8 + unsigned int version = POLARSSL_VERSION_NUMBER;
9 return snprintf(buffer, size, "%s/%d.%d.%d",
10 version >= 0x01030A00?"mbedTLS":"PolarSSL",
11 version>>24, (version>>16)&0xff, (version>>8)&0xff);
12 --- a/lib/vtls/mbedtls.c
13 +++ b/lib/vtls/mbedtls.c
14 @@ -724,7 +724,7 @@ void Curl_mbedtls_session_free(void *ptr
15
16 size_t Curl_mbedtls_version(char *buffer, size_t size)
17 {
18 - unsigned int version = mbedtls_version_get_number();
19 + unsigned int version = MBEDTLS_VERSION_NUMBER;
20 return snprintf(buffer, size, "mbedTLS/%d.%d.%d", version>>24,
21 (version>>16)&0xff, (version>>8)&0xff);
22 }