ath79: add etactica-eg200 support
[openwrt/openwrt.git] / target / linux / ath79 / base-files / etc / board.d / 01_leds
1 #!/bin/sh
2
3 . /lib/functions/uci-defaults.sh
4
5 board_config_update
6
7 board=$(board_name)
8 boardname="${board##*,}"
9
10 case "$board" in
11 "avm,fritz300e")
12 ucidef_set_led_netdev "lan" "LAN" "$boardname:green:lan" "eth0"
13 ucidef_set_led_wlan "wlan" "WLAN" "$boardname:green:wlan" "phy0tpt"
14 ucidef_set_rssimon "wlan0" "200000" "1"
15 ucidef_set_led_rssi "rssilow" "RSSILOW" "$boardname:green:rssi0" "wlan0" "1" "100"
16 ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "$boardname:green:rssi1" "wlan0" "20" "100"
17 ucidef_set_led_rssi "rssimedium" "RSSIMEDIUM" "$boardname:green:rssi2" "wlan0" "40" "100"
18 ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "$boardname:green:rssi3" "wlan0" "60" "100"
19 ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "$boardname:green:rssi4" "wlan0" "80" "100"
20 ;;
21 "etactica,eg200")
22 ucidef_set_led_netdev "lan" "LAN" "$boardname:red:eth0" "eth0"
23 ucidef_set_led_wlan "wlan" "WLAN" "$boardname:red:wlan" "phy0tpt"
24 ucidef_set_led_oneshot "modbus" "Modbus" "$boardname:red:modbus" "100" "33"
25 ucidef_set_led_default "etactica" "etactica" "$boardname:red:etactica" "ignore"
26 ;;
27 "glinet,ar150")
28 ucidef_set_led_wlan "wlan" "WLAN" "gl-ar150:orange:wlan" "phy0tpt"
29 ;;
30 "tplink,tl-wr740n-v2")
31 ucidef_set_led_netdev "wan" "WAN" "$boardname:green:wan" "eth0"
32 ucidef_set_led_switch "lan1" "LAN1" "$boardname:green:lan1" "switch0" "0x02"
33 ucidef_set_led_switch "lan2" "LAN2" "$boardname:green:lan2" "switch0" "0x04"
34 ucidef_set_led_switch "lan3" "LAN3" "$boardname:green:lan3" "switch0" "0x08"
35 ucidef_set_led_switch "lan4" "LAN4" "$boardname:green:lan4" "switch0" "0x10"
36 ;;
37 "tplink,tl-wr1043nd-v1")
38 ucidef_set_led_usbdev "usb" "USB" "tp-link:green:usb" "1-1"
39 ucidef_set_led_wlan "wlan" "WLAN" "tp-link:green:wlan" "phy0tpt"
40 ;;
41 esac
42
43 board_config_flush
44
45 exit 0