add support for Linaro binutils 2.23.2-2013.06
[openwrt/openwrt.git] / toolchain / binutils / Config.in
1 # Choose binutils version.
2
3 choice
4 prompt "Binutils Version" if TOOLCHAINOPTS
5 default BINUTILS_VERSION_2_20_1 if avr32
6 default BINUTILS_VERSION_2_22 if !avr32
7 help
8 Select the version of binutils you wish to use.
9
10 config BINUTILS_VERSION_2_20_1
11 depends on avr32
12 bool "binutils 2.20.1"
13
14 config BINUTILS_VERSION_2_22
15 depends on !avr32 || (avr32 && BROKEN)
16 bool "binutils 2.22"
17
18 config BINUTILS_VERSION_2_23_1
19 depends on !avr32 || (avr32 && BROKEN)
20 bool "binutils 2.23.1"
21
22 config BINUTILS_VERSION_LINARO
23 depends on !avr32 || (avr32 && BROKEN)
24 bool "Linaro binutils 2.23.2"
25
26 endchoice
27
28 config EXTRA_BINUTILS_CONFIG_OPTIONS
29 string
30 prompt "Additional binutils configure options" if TOOLCHAINOPTS
31 default ""
32 help
33 Any additional binutils options you may want to include....
34
35 config BINUTILS_VERSION
36 string
37 prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
38 default "2.20.1" if BINUTILS_VERSION_2_20_1
39 default "2.22" if BINUTILS_VERSION_2_22
40 default "2.23.1" if BINUTILS_VERSION_2_23_1
41 default "linaro" if BINUTILS_VERSION_LINARO
42 default "2.20.1" if avr32
43 default "2.22"