switch to binutils 2.19.1 by default
[openwrt/openwrt.git] / toolchain / binutils / Config.in
1 # Choose binutils version.
2
3 choice
4 prompt "Binutils Version" if TOOLCHAINOPTS
5 default BINUTILS_VERSION_2_18 if TARGET_avr32
6 default BINUTILS_VERSION_2_18 if TARGET_ppc44x || TARGET_ppc40x
7 default BINUTILS_VERSION_2_19_1
8 help
9 Select the version of binutils you wish to use.
10
11 config BINUTILS_VERSION_2_17
12 bool "binutils 2.17"
13
14 config BINUTILS_VERSION_2_18
15 bool "binutils 2.18"
16
17 config BINUTILS_VERSION_2_19
18 depends !TARGET_avr32
19 bool "binutils 2.19"
20
21 config BINUTILS_VERSION_2_19_1
22 depends !TARGET_avr32
23 bool "binutils 2.19.1"
24 endchoice
25
26 config EXTRA_BINUTILS_CONFIG_OPTIONS
27 string
28 prompt "Additional binutils options" if TOOLCHAINOPTS
29 default ""
30 help
31 Any additional binutils options you may want to include....
32
33 config BINUTILS_VERSION
34 string
35 prompt "Binutils Version" if (TOOLCHAINOPTS && NULL)
36 default "2.17" if BINUTILS_VERSION_2_17
37 default "2.18" if BINUTILS_VERSION_2_18
38 default "2.19" if BINUTILS_VERSION_2_19
39 default "2.19.1" if BINUTILS_VERSION_2_19_1
40 default "2.18" if TARGET_avr32
41 default "2.18" if TARGET_ppc44x || TARGET_ppc40x
42 default "2.17"