eglibc: remove old versions
[openwrt/openwrt.git] / toolchain / eglibc / Config.in
1 choice
2 prompt "eglibc version"
3 depends on TOOLCHAINOPTS && USE_EGLIBC
4 default EGLIBC_VERSION_2_12
5 help
6 Select the version of eglibc you wish to use.
7
8 config EGLIBC_VERSION_2_12
9 bool "eglibc 2.12"
10 depends !GCC_VERSION_LLVM
11
12 config EGLIBC_VERSION_2_13
13 bool "eglibc 2.13"
14 depends !GCC_VERSION_LLVM
15
16 config EGLIBC_VERSION_TRUNK
17 bool "eglibc trunk"
18
19 endchoice
20
21 config EGLIBC_REVISION
22 string
23 prompt "eglibc revision"
24 depends on TOOLCHAINOPTS && USE_EGLIBC
25 default "10495" if EGLIBC_VERSION_2_12
26 default "13055" if EGLIBC_VERSION_2_13
27 default "HEAD" if EGLIBC_VERSION_TRUNK
28 default ""
29
30 menu "eglibc configuration"
31 depends on TOOLCHAINOPTS && USE_EGLIBC
32 source toolchain/eglibc/config/Config.in
33 endmenu