toolchain/gcc: add support for 4.8-linaro
[openwrt/openwrt.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_USE_VERSION_4_4_7 if GCC_DEFAULT_VERSION_4_4_7
6 default GCC_USE_VERSION_4_6_LINARO
7 help
8 Select the version of gcc you wish to use.
9
10 config GCC_USE_VERSION_4_4_7
11 select GCC_VERSION_4_4_7
12 bool "gcc 4.4.7"
13 depends on avr32
14
15 config GCC_USE_VERSION_4_6_3
16 select GCC_VERSION_4_6_3
17 bool "gcc 4.6.3"
18
19 config GCC_USE_VERSION_4_7_2
20 select GCC_VERSION_4_7_2
21 bool "gcc 4.7.2"
22
23 config GCC_USE_VERSION_4_8_0
24 select GCC_VERSION_4_8_0
25 bool "gcc 4.8.0"
26
27 config GCC_USE_VERSION_4_6_LINARO
28 select GCC_VERSION_4_6_LINARO
29 bool "gcc 4.6.x with Linaro enhancements"
30
31 config GCC_USE_VERSION_4_7_LINARO
32 select GCC_VERSION_4_7_LINARO
33 bool "gcc 4.7.x with Linaro enhancements"
34
35 config GCC_USE_VERSION_4_8_LINARO
36 select GCC_VERSION_4_8_LINARO
37 bool "gcc 4.8.x with Linaro enhancements"
38
39 endchoice
40
41 config GCC_USE_GRAPHITE
42 bool
43 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
44
45 config GCC_USE_SYSTEM_PPL_CLOOG
46 bool
47 prompt "Use the system versions of PPL and CLooG"
48 depends on GCC_USE_GRAPHITE
49 default n
50
51 config EXTRA_GCC_CONFIG_OPTIONS
52 string
53 prompt "Additional gcc configure options" if TOOLCHAINOPTS
54 default ""
55 help
56 Any additional gcc options you may want to include....
57
58 config SSP_SUPPORT
59 bool
60 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
61 default n
62 help
63 Enable Stack-Smashing Protection support
64
65 config SJLJ_EXCEPTIONS
66 bool
67 prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
68 default n
69 help
70 Use old setjump()/longjump() exceptions instead of the newer
71 frame unwinding exceptions handling routines. Warning: increases
72 code size and runtime memory usage.
73
74 config INSTALL_LIBSTDCPP
75 bool
76 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
77 default y if !USE_MUSL
78 help
79 Build/install c++ compiler and libstdc++?
80
81 config INSTALL_LIBGCJ
82 bool
83 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
84 default n
85 help
86 Build/install java compiler and GNU classpath ?
87
88
89 config INSTALL_GFORTRAN
90 bool
91 prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
92 default n
93 help
94 Build/install GNU fortran compiler ?