toolchain: get rid of eglibc version kconfig symbol overloading
[openwrt/openwrt.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_USE_VERSION_4_4_7 if GCC_DEFAULT_VERSION_4_4_7
6 default GCC_USE_VERSION_4_6_LINARO
7 help
8 Select the version of gcc you wish to use.
9
10 config GCC_USE_VERSION_4_4_7
11 select GCC_VERSION_4_4_7
12 bool "gcc 4.4.7"
13 depends on avr32
14
15 config GCC_USE_VERSION_4_6_3
16 select GCC_VERSION_4_6_3
17 bool "gcc 4.6.3"
18
19 config GCC_USE_VERSION_4_7_2
20 select GCC_VERSION_4_7_2
21 bool "gcc 4.7.2"
22
23 config GCC_USE_VERSION_4_6_LINARO
24 select GCC_VERSION_4_6_LINARO
25 bool "gcc 4.6.x with Linaro enhancements"
26
27 config GCC_USE_VERSION_4_7_LINARO
28 select GCC_VERSION_4_7_LINARO
29 bool "gcc 4.7.x with Linaro enhancements"
30
31 config GCC_USE_VERSION_4_8_0
32 select GCC_VERSION_4_8_0
33 bool "gcc 4.8.0"
34
35 endchoice
36
37 config GCC_USE_GRAPHITE
38 bool
39 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
40
41 config GCC_USE_SYSTEM_PPL_CLOOG
42 bool
43 prompt "Use the system versions of PPL and CLooG"
44 depends on GCC_USE_GRAPHITE
45 default n
46
47 config EXTRA_GCC_CONFIG_OPTIONS
48 string
49 prompt "Additional gcc configure options" if TOOLCHAINOPTS
50 default ""
51 help
52 Any additional gcc options you may want to include....
53
54 config SSP_SUPPORT
55 bool
56 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
57 default n
58 help
59 Enable Stack-Smashing Protection support
60
61 config SJLJ_EXCEPTIONS
62 bool
63 prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
64 default n
65 help
66 Use old setjump()/longjump() exceptions instead of the newer
67 frame unwinding exceptions handling routines. Warning: increases
68 code size and runtime memory usage.
69
70 config INSTALL_LIBSTDCPP
71 bool
72 prompt "Build/install c++ compiler and libstdc++?" if TOOLCHAINOPTS
73 default y if !USE_MUSL
74 help
75 Build/install c++ compiler and libstdc++?
76
77 config INSTALL_LIBGCJ
78 bool
79 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
80 default n
81 help
82 Build/install java compiler and GNU classpath ?
83
84
85 config INSTALL_GFORTRAN
86 bool
87 prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
88 default n
89 help
90 Build/install GNU fortran compiler ?