f5de52db6f10891ed1dcf85c6a36156e51ee0417
[openwrt/openwrt.git] / toolchain / gcc / Config.in
1 # Choose gcc version.
2
3 choice
4 prompt "GCC compiler Version" if TOOLCHAINOPTS
5 default GCC_USE_VERSION_4_6_LINARO if TARGET_octeon
6 default GCC_USE_VERSION_4_8_LINARO
7 help
8 Select the version of gcc you wish to use.
9
10 config GCC_USE_VERSION_4_6_LINARO
11 select GCC_VERSION_4_6_LINARO
12 bool "gcc 4.6.x with Linaro enhancements"
13
14 config GCC_USE_VERSION_4_8_LINARO
15 select GCC_VERSION_4_8_LINARO
16 bool "gcc 4.8.x with Linaro enhancements"
17
18 config GCC_USE_VERSION_4_9_LINARO
19 select GCC_VERSION_4_9_LINARO
20 bool "gcc 4.9.x with Linaro enhancements"
21 depends on BROKEN
22
23 config GCC_USE_VERSION_5
24 select GCC_VERSION_5
25 bool "gcc 5.x"
26 depends on BROKEN
27
28 endchoice
29
30 config GCC_USE_GRAPHITE
31 bool
32 prompt "Compile in support for the new Graphite framework in GCC 4.4+" if TOOLCHAINOPTS
33
34 config GCC_USE_SYSTEM_PPL_CLOOG
35 bool
36 prompt "Use the system versions of PPL and CLooG"
37 depends on GCC_USE_GRAPHITE
38 default n
39
40 config EXTRA_GCC_CONFIG_OPTIONS
41 string
42 prompt "Additional gcc configure options" if TOOLCHAINOPTS
43 default ""
44 help
45 Any additional gcc options you may want to include....
46
47 config SSP_SUPPORT
48 bool
49 prompt "Enable Stack-Smashing Protection support" if TOOLCHAINOPTS
50 depends on !USE_MUSL
51 default y if !USE_MUSL
52 help
53 Enable Stack-Smashing Protection support
54
55 config SJLJ_EXCEPTIONS
56 bool
57 prompt "Use setjump()/longjump() exceptions" if TOOLCHAINOPTS
58 default n
59 help
60 Use old setjump()/longjump() exceptions instead of the newer
61 frame unwinding exceptions handling routines. Warning: increases
62 code size and runtime memory usage.
63
64 config INSTALL_LIBGCJ
65 bool
66 prompt "Build/install java compiler and GNU classpath ?" if TOOLCHAINOPTS
67 default n
68 help
69 Build/install java compiler and GNU classpath ?
70
71
72 config INSTALL_GFORTRAN
73 bool
74 prompt "Build/install fortran compiler?" if TOOLCHAINOPTS
75 default n
76 help
77 Build/install GNU fortran compiler ?