toolchain: fix selecting older gcc versions for x86
[openwrt/openwrt.git] / toolchain / gcc / Config.version
1 config GCC_VERSION_7_1_ARC
2 default y if (!TOOLCHAINOPTS && arc)
3 bool
4
5 config GCC_VERSION_7
6 default y if GCC_USE_VERSION_7
7 default y if (!TOOLCHAINOPTS && x86_64)
8 default y if (!TOOLCHAINOPTS && i386)
9 bool
10
11 config GCC_VERSION
12 string
13 default "arc-2017.09-release" if GCC_VERSION_7_1_ARC
14 default "6.3.0" if GCC_USE_VERSION_6
15 default "7.3.0" if GCC_VERSION_7
16 default "5.5.0"