use gcc 4.1.1 for 2.6, 3.4.6 for 2.4 targets by default
[openwrt/openwrt.git] / toolchain / gcc / Config.version
1 config GCC_VERSION
2 string
3 default "3.4.4" if GCC_VERSION_3_4_4
4 default "3.4.5" if GCC_VERSION_3_4_5
5 default "3.4.6" if GCC_VERSION_3_4_6
6 default "4.0.2" if GCC_VERSION_4_0_2
7 default "4.0.3" if GCC_VERSION_4_0_3
8 default "4.1.0" if GCC_VERSION_4_1_0
9 default "4.1.1" if GCC_VERSION_4_1_1
10 default "4.2" if GCC_VERSION_4_2
11 default "3.4.6-nonmips" if GCC_VERSION_3_4_6_nonmips
12 default "4.1.1"
13
14 if !TOOLCHAINOPTS
15 config GCC_VERSION_4_2
16 default n
17
18 config GCC_VERSION_3_4_6
19 default y if LINUX_2_4
20 endif
21
22