tools/expat: Update to 2.2.4
[openwrt/openwrt.git] / tools / e2fsprogs / patches / 010-old-libmagic.patch
1 From b482eb7af94885b6bbad9329e40702c958d5b448 Mon Sep 17 00:00:00 2001
2 From: Hauke Mehrtens <hauke@hauke-m.de>
3 Date: Thu, 30 Jun 2016 19:53:03 +0200
4 Subject: [PATCH] fix build problem with very old libmagic
5
6 The libmagic shipped with RedHat 5 does not define
7 MAGIC_NO_CHECK_ELF and MAGIC_NO_CHECK_COMPRESS. e2fsprogs should
8 check for that otherwise the build will fail.
9
10 Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
11 ---
12 lib/support/plausible.c | 2 +-
13 1 file changed, 1 insertion(+), 1 deletion(-)
14
15 --- a/lib/support/plausible.c
16 +++ b/lib/support/plausible.c
17 @@ -258,7 +258,7 @@ int check_plausibility(const char *devic
18 return 0;
19 }
20
21 -#ifdef HAVE_MAGIC_H
22 +#if defined(HAVE_MAGIC_H) && defined(MAGIC_NO_CHECK_ELF) && defined(MAGIC_NO_CHECK_COMPRESS)
23 if ((flags & CHECK_FS_EXIST) &&
24 !getenv("E2FSPROGS_LIBMAGIC_SUPPRESS") &&
25 magic_library_available()) {