3e71ad5b07502cfccbebeabdac719d2a2e2c8784
[openwrt/openwrt.git] / tools / mkimage / patches / 080-remove_compiler_check.patch
1 --- a/include/linux/compiler-gcc4.h
2 +++ b/include/linux/compiler-gcc4.h
3 @@ -2,13 +2,6 @@
4 #error "Please don't include <linux/compiler-gcc4.h> directly, include <linux/compiler.h> instead."
5 #endif
6
7 -/* GCC 4.1.[01] miscompiles __weak */
8 -#ifdef __KERNEL__
9 -# if GCC_VERSION >= 40100 && GCC_VERSION <= 40101
10 -# error Your version of gcc miscompiles the __weak directive
11 -# endif
12 -#endif
13 -
14 #define __used __attribute__((__used__))
15 #define __must_check __attribute__((warn_unused_result))
16 #define __compiler_offsetof(a,b) __builtin_offsetof(a,b)