rules.mk: use qstrip to reduce syntax highlighting issues
[openwrt/openwrt.git] / Config.in
index 98e3e046f99085359cbbd40d67810ecc650d962a..97aef0f3442436f5ea3029831c736b9a389daa48 100644 (file)
--- a/Config.in
+++ b/Config.in
@@ -230,6 +230,11 @@ menu "Global build settings"
                bool "Compile the kernel with tracing support"
                default n
 
+       config KERNEL_FTRACE_SYSCALLS
+               bool "Trace system calls"
+               depends on KERNEL_FTRACE
+               default n
+
        config KERNEL_ENABLE_DEFAULT_TRACERS
                bool "Trace process context switches and events"
                depends on KERNEL_FTRACE
@@ -303,6 +308,9 @@ menu "Global build settings"
        config KERNEL_RELAY
                bool
 
+       config KERNEL_KEXEC
+               bool "Enable kexec support"
+
        #
        # CGROUP support symbols
        #
@@ -440,13 +448,10 @@ menu "Global build settings"
                          the kmem extension can use it to guarantee that no group of processes
                          will ever exhaust kernel resources alone.
 
-               config KERNEL_PERF_EVENTS
-                       bool
-                       default y if KERNEL_CGROUP_PERF
-
                config KERNEL_CGROUP_PERF
                        bool "Enable perf_event per-cpu per-container group (cgroup) monitoring"
                        default n
+                       select KERNEL_PERF_EVENTS
                        help
                          This option extends the per-cpu mode to restrict monitoring to
                          threads which belong to the cgroup specified and run on the