Using find's -exec to remove directories causes 'not found' errors when find tries...
[openwrt/openwrt.git] / Makefile
index b1970b09cb1e895d084c4d1701e537d1ccff46d5..05c4f450e1f04bcc34b96073ee006daa1e04a498 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,44 +39,18 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
-  tmp/.pkginfo: FORCE
-endif
-
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
-  tmp/.targetinfo: FORCE
-endif
-
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
   world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-ifeq ($(IS_TTY),1)
-  define progress
-       printf "\033[M\r$(1)" >&2;
-  endef
-endif
+tmp/.pkginfo: FORCE
+       @mkdir -p tmp/info
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="pkginfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(shell ls include/package*.mk) include/kernel.mk" SCAN_EXTRA=""
 
-define dumpinfo
-       @mkdir -p tmp
-       @echo -n Collecting $(2) info... 
-       @-for dir in $(1)/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               $(call progress,Collecting $(2) info: $${dir%%/}) \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
-               echo; \
-       done > $@
-       @($(call progress,Collecting $(2) info: done))
-       @echo
-endef
-
-tmp/.pkginfo:
-       $(call dumpinfo,package,package)
-
-tmp/.targetinfo:
-       $(call dumpinfo,target/linux,target)
+tmp/.targetinfo: FORCE
+       @mkdir -p tmp/info
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="$(shell ls include/kernel*.mk)" SCAN_EXTRA=""
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
@@ -114,13 +88,18 @@ menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
 kernel_menuconfig: .config FORCE
-       $(MAKE) target/linux-prepare
+       -$(MAKE) target/linux-prepare
        $(NO_TRACE_MAKE) -C target/linux menuconfig
 
-package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+scan_packages:
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
+       
+
+package/%: scan_packages
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+target/%: scan_packages
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
 tools/%: FORCE
@@ -179,7 +158,7 @@ clean: FORCE
 dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
-distclean: dirclean config-clean
+distclean: dirclean config-clean symlinkclean docclean
        rm -rf dl
 
 help:
@@ -191,7 +170,10 @@ doc:
 docclean:
        $(MAKE) -C docs/ clean
 
-.SILENT: clean dirclean distclean config-clean download world
+symlinkclean:
+       find package -type l -exec rm -f {} +
+
+.SILENT: clean dirclean distclean symlinkclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help
 %: ;