move "make symlinks" to "make package/symlinks"
[openwrt/openwrt.git] / Makefile
index 447457e2694f7d1a45334ce3d672e8ae2cda4618..35fc2c8884e036ae93e656f9c538ae90acc614c9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -60,32 +60,32 @@ endif
 
 define dumpinfo
        @mkdir -p tmp
-       @echo -n Collecting package info... 
+       @echo -n Collecting $(2) info... 
        @-for dir in $(1)/*/; do \
                [ -f "$${dir}/Makefile" ] || continue; \
-               $(call progress,Collecting package info... $${dir%%/}) \
+               $(call progress,Collecting $(2) info: $${dir%%/}) \
                echo Source-Makefile: $${dir}Makefile; \
                $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
                echo; \
        done > $@
-       $(call progress,Collecting package info... done)
-       echo
+       @($(call progress,Collecting $(2) info: done))
+       @echo
 endef
 
 tmp/.pkginfo:
-       $(call dumpinfo,package)
+       $(call dumpinfo,package,package)
 
 tmp/.targetinfo:
-       $(call dumpinfo,target/linux)
+       $(call dumpinfo,target/linux,target)
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -181,6 +181,12 @@ distclean: dirclean config-clean
 help:
        cat README
 
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help