abort built in prereq target if there is no site config file for the current target
[openwrt/openwrt.git] / Makefile
index 4d5d7885e00494ab51a8e7a1e920a7089cfd2268..44b4e944eb9b5a46d68786d8a5473f9455589690 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -78,6 +78,12 @@ endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
+       @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
+               echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+               echo '       The missing file will cause configure scripts to fail during compilation.'; \
+               echo '       Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+               exit 1; \
+       fi
 
 prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE