generate package for the new IXP4xx crpyto driver
[openwrt/openwrt.git] / Makefile
index be53622cc18069c9882c8a0515af9f5d3d650258..72b24d14e7c71a952fd57360015e3f2ab2b44e0a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -6,43 +6,77 @@
 # See /LICENSE for more information.
 #
 
-all: world
-
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-IS_TTY:=${shell tty -s && echo 1 || echo 0}
-export TOPDIR LC_ALL LANG IS_TTY
+export TOPDIR LC_ALL LANG
+
+world:
+
+include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
-  export OPENWRT_BUILD:=1
+  # XXX: these three lines are normally defined by rules.mk
+  # but we can't include that file in this context
+  empty:=
+  space:= $(empty) $(empty)
+  _SINGLE=MAKEFLAGS=$(space)
+
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
+  include $(TOPDIR)/include/depends.mk
   include $(TOPDIR)/include/toplevel.mk
 else
-  include $(TOPDIR)/include/host.mk
-
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
+  include target/Makefile
+  include package/Makefile
   include tools/Makefile
   include toolchain/Makefile
 
+$(toolchain/stamp-install): $(tools/stamp-install)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(package/stamp-cleanup): $(target/stamp-compile)
+$(package/stamp-compile): $(target/stamp-compile) $(package/stamp-cleanup)
+$(package/stamp-install): $(package/stamp-compile)
+$(package/stamp-rootfs-prepare): $(package/stamp-install)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare)
+
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
+
 clean: FORCE
-       rm -rf build_* bin tmp
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
+       $(SUBMAKE) target/linux/clean
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_* tool_build
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST)
+       rm -rf $(TMP_DIR)
+
+# check prerequisites before starting to build
+prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
+
+prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
+world: prepare $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
+       $(SUBMAKE) package/index
+
+# update all feeds, re-create index files, install symlinks
+package/symlinks:
+       $(SCRIPT_DIR)/feeds update -a
+       $(SCRIPT_DIR)/feeds install -a
 
-distclean: dirclean config-clean symlinkclean docs/clean
-       rm -rf dl
+# re-create index files, install symlinks
+package/symlinks-install:
+       $(SCRIPT_DIR)/feeds update -i
+       $(SCRIPT_DIR)/feeds install -a
 
-package/% target/%: FORCE
-       $(MAKE) -C $(patsubst %/$*,%,$@) $*
+# remove all symlinks, don't touch ./feeds
+package/symlinks-clean:
+       $(SCRIPT_DIR)/feeds uninstall -a
 
-world: .config $(tools/stamp) $(toolchain/stamp) FORCE
-       $(MAKE) target/compile
-       $(MAKE) package/compile
-       $(MAKE) package/install
-       $(MAKE) target/install
-       $(MAKE) package/index
+.PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif