ar71xx: add kernel support for the OpenMesh OM5P-AN board
[openwrt/openwrt.git] / Makefile
index 348e64500592d502b100ec2e5cb9fe96d6534f2d..91b6946ac3420c8d7272807a809bb418f3f99103 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -11,15 +11,15 @@ LC_ALL:=C
 LANG:=C
 export TOPDIR LC_ALL LANG
 
+empty:=
+space:= $(empty) $(empty)
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+
 world:
 
 include $(TOPDIR)/include/host.mk
 
 ifneq ($(OPENWRT_BUILD),1)
-  # XXX: these three lines are normally defined by rules.mk
-  # but we can't include that file in this context
-  empty:=
-  space:= $(empty) $(empty)
   _SINGLE=export MAKEFLAGS=$(space);
 
   override OPENWRT_BUILD=1
@@ -50,7 +50,6 @@ printdb:
 prepare: $(target/stamp-compile)
 
 clean: FORCE
-       $(_SINGLE)$(SUBMAKE) target/linux/clean
        rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
 
 dirclean: clean