move TARGET_* flags from ./include/package-default.mk to ./rules.mk, remove EXTRA_...
[openwrt/openwrt.git] / Makefile
index a039c9880b41e736106179974aba11f32aa99bda..a5e03d1cb3c48fc09ecc3ff3b43da4bf345f5fb9 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -6,43 +6,54 @@
 # See /LICENSE for more information.
 #
 
-all: world
-
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
 IS_TTY:=${shell tty -s && echo 1 || echo 0}
 export TOPDIR LC_ALL LANG IS_TTY
 
+world:
+
+include $(TOPDIR)/include/host.mk
+
 ifneq ($(OPENWRT_BUILD),1)
-  export OPENWRT_BUILD:=1
+  override OPENWRT_BUILD=1
+  export OPENWRT_BUILD
+  include $(TOPDIR)/include/debug.mk
   include $(TOPDIR)/include/toplevel.mk
 else
-  include $(TOPDIR)/include/host.mk
-
   include rules.mk
   include $(INCLUDE_DIR)/depends.mk
   include $(INCLUDE_DIR)/subdir.mk
+  include target/Makefile
+  include package/Makefile
   include tools/Makefile
   include toolchain/Makefile
 
+$(toolchain/stamp-compile): $(tools/stamp-compile)
+$(target/stamp-compile): $(toolchain/stamp-install) $(tools/stamp-install) $(BUILD_DIR)/.prepared
+$(package/stamp-compile): $(target/stamp-compile)
+$(target/stamp-install): $(package/stamp-compile) $(package/stamp-install)
+
+$(BUILD_DIR)/.prepared: Makefile
+       @mkdir -p $$(dirname $@)
+       @touch $@
+
 clean: FORCE
-       rm -rf build_* bin tmp
+       rm -rf $(BUILD_DIR) $(BIN_DIR)
+       $(MAKE) target/linux/clean
+       rm -rf $(TMP_DIR)
 
 dirclean: clean
-       rm -rf staging_dir_* toolchain_build_* tool_build
+       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(BUILD_DIR_TOOLCHAIN) $(BUILD_DIR_HOST)
 
-distclean: dirclean config-clean symlinkclean docs/clean
-       rm -rf dl
+# check prerequisites before starting to build
+prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-toolchain/% package/% target/%: FORCE
-       $(MAKE) -C $(patsubst %/$*,%,$@) $*
-
-world: .config $(tools/stamp) $(toolchain/stamp) FORCE
-       $(MAKE) target/compile
-       $(MAKE) package/compile
-       $(MAKE) package/install
-       $(MAKE) target/install
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
+package/symlinks:
+       $(SCRIPT_DIR)/feeds.sh $(CONFIG_SOURCE_FEEDS) $(CONFIG_SOURCE_FEEDS_REV)        
+
 endif