color change to make menuconfig easier to read (patch from #1730)
[openwrt/openwrt.git] / Makefile
index b1fe29edc638e1167df20c6e5368188f35d13d43..b798f723c82565a4792620519c989eab0b2fa253 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -21,9 +21,6 @@ SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
 export TOPDIR=${CURDIR}
-ifeq ($(KBUILD_VERBOSE),99)
-  MAKE:=3>/dev/null $(MAKE)
-endif
 export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 include $(TOPDIR)/include/verbose.mk
@@ -47,23 +44,20 @@ endif
 package/%/Makefile: ;
 target/%/Makefile: ;
 
-tmp/.packageinfo: $(wildcard package/*/Makefile include/package*.mk include/kernel.mk) 
-tmp/.targetinfo: $(wildcard target/*/Makefile include/kernel*.mk)
-tmp/.%info:
+tmp/.packageinfo tmp/.targetinfo: FORCE
        mkdir -p tmp/info
-       $(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$*info" SCAN_DIR="$(patsubst target,target/linux,$*)" SCAN_NAME="$*" SCAN_DEPS="$^" SCAN_EXTRA=""
+       $(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="targetinfo" SCAN_DIR="target/linux" SCAN_NAME="target" SCAN_DEPS="" SCAN_TARGET_DEPS="$(wildcard target/*/Makefile include/kernel*.mk)" SCAN_EXTRA=""
+       $(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="packageinfo" SCAN_DIR="package" SCAN_NAME="package" SCAN_DEPS="$(wildcard package/*/Makefile include/package*.mk include/kernel.mk)" SCAN_EXTRA=""
 
 tmpinfo-clean: FORCE
        -rm -rf tmp/.*info
 
-tmp/.config-%.in: tmp/.%info
+tmp/.config-%.in: tmp/.%info scripts/metadata.pl
        ./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
 
-
-
 .config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
-       if [ \! -f .config -a -e $(HOME)/.openwrt/defconfig ]; then \ 
-               cp $(HOME)/.openwrt/defconfig .config; \
+       if [ \! -f .config ]; then \
+               [ -e $(HOME)/.openwrt/defconfig ] && cp $(HOME)/.openwrt/defconfig .config; \
                $(NO_TRACE_MAKE) menuconfig; \
        fi
        $< -D .config Config.in &> /dev/null
@@ -153,15 +147,16 @@ distclean: dirclean config-clean symlinkclean docclean
 help:
        cat README
 
-doc:
-       $(MAKE) -C docs/ openwrt.pdf
+docs docs/compile: FORCE
+       $(MAKE) -C docs compile
 
-docclean:
-       $(MAKE) -C docs/ clean
+docs/clean: FORCE
+       $(MAKE) -C docs clean
 
 symlinkclean:
-       find package -type l -exec rm -f {} +
+       -find package -type l | xargs rm -f
+       rm -rf tmp
 
-.SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.%info tmpinfo-clean tmp/.config-%.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-%
+.SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;
 .PHONY: FORCE help