remove a warning that has confused a few people
[openwrt/openwrt.git] / Makefile
index e2430164fe992a3671e3ea4760578c24c33f3259..b798f723c82565a4792620519c989eab0b2fa253 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -147,14 +147,15 @@ distclean: dirclean config-clean symlinkclean docclean
 help:
        cat README
 
-doc:
-       $(MAKE) -C docs/ openwrt.pdf
+docs docs/compile: FORCE
+       $(MAKE) -C docs compile
 
-docclean:
-       $(MAKE) -C docs/ clean
+docs/clean: FORCE
+       $(MAKE) -C docs clean
 
 symlinkclean:
        -find package -type l | xargs rm -f
+       rm -rf tmp
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;