netifd: Use -x hostname:$hostname instead of -H
[openwrt/openwrt.git] / Makefile
index 91b6946ac3420c8d7272807a809bb418f3f99103..c3e1ed77076feec19eeb171a780fa895a5dca6d8 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -9,11 +9,12 @@
 TOPDIR:=${CURDIR}
 LC_ALL:=C
 LANG:=C
-export TOPDIR LC_ALL LANG
+TZ:=UTC
+export TOPDIR LC_ALL LANG TZ
 
 empty:=
 space:= $(empty) $(empty)
-$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the OpenWrt directory must not include any spaces))
+$(if $(findstring $(space),$(TOPDIR)),$(error ERROR: The path to the LEDE directory must not include any spaces))
 
 world:
 
@@ -50,10 +51,10 @@ printdb:
 prepare: $(target/stamp-compile)
 
 clean: FORCE
-       rm -rf $(BUILD_DIR) $(BIN_DIR) $(BUILD_LOG_DIR)
+       rm -rf $(BUILD_DIR) $(STAGING_DIR) $(BIN_DIR) $(OUTPUT_DIR)/packages/$(ARCH_PACKAGES) $(BUILD_LOG_DIR)
 
 dirclean: clean
-       rm -rf $(STAGING_DIR) $(STAGING_DIR_HOST) $(STAGING_DIR_TOOLCHAIN) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
+       rm -rf $(STAGING_DIR_HOST) $(TOOLCHAIN_DIR) $(BUILD_DIR_HOST) $(BUILD_DIR_TOOLCHAIN)
        rm -rf $(TMP_DIR)
 
 ifndef DUMP_TARGET_DB
@@ -75,10 +76,10 @@ endif
 
 # check prerequisites before starting to build
 prereq: $(target/stamp-prereq) tmp/.prereq_packages
-       @if [ ! -f "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" ]; then \
-               echo 'ERROR: Missing site config for target "$(REAL_GNU_TARGET_NAME)" !'; \
+       @if [ ! -f "$(INCLUDE_DIR)/site/$(ARCH)" ]; then \
+               echo 'ERROR: Missing site config for architecture "$(ARCH)" !'; \
                echo '       The missing file will cause configure scripts to fail during compilation.'; \
-               echo '       Please provide a "$(INCLUDE_DIR)/site/$(REAL_GNU_TARGET_NAME)" file and restart the build.'; \
+               echo '       Please provide a "$(INCLUDE_DIR)/site/$(ARCH)" file and restart the build.'; \
                exit 1; \
        fi
 
@@ -86,20 +87,6 @@ prepare: .config $(tools/stamp-install) $(toolchain/stamp-install)
 world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
        $(_SINGLE)$(SUBMAKE) -r package/index
 
-# update all feeds, re-create index files, install symlinks
-package/symlinks:
-       $(SCRIPT_DIR)/feeds update -a
-       $(SCRIPT_DIR)/feeds install -a
-
-# re-create index files, install symlinks
-package/symlinks-install:
-       $(SCRIPT_DIR)/feeds update -i
-       $(SCRIPT_DIR)/feeds install -a
-
-# remove all symlinks, don't touch ./feeds
-package/symlinks-clean:
-       $(SCRIPT_DIR)/feeds uninstall -a
-
 .PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif