madwifi: remove stuck beacon workaround (does not work properly). add a workaround...
[openwrt/openwrt.git] / Makefile
index 50cf8c985b221054c6caaa712e6ca7fc2d76f70b..e035faac2598135a8ce418c793e8ef349f81a600 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -42,13 +42,13 @@ clean: FORCE
 dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
-distclean: dirclean config-clean symlinkclean docs/clean
-       rm -rf dl
+distclean: dirclean 
+       rm -rf dl .config*
 
 # check prerequisites before starting to build
 prereq: $(package/stamp-prereq) $(target/stamp-prereq) ;
 
-world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-install) $(target/stamp-install) FORCE
+world: .config $(tools/stamp-install) $(toolchain/stamp-install) $(target/stamp-compile) $(package/stamp-cleanup) $(package/stamp-compile) $(package/stamp-install) $(package/stamp-rootfs-prepare) $(target/stamp-install) FORCE
        $(MAKE) package/index
 
 package/symlinks: