upgrade dnsmasq (#1975)
[openwrt/openwrt.git] / Makefile
index e2430164fe992a3671e3ea4760578c24c33f3259..f4b153c17e2bb3bb11999874f898de6d497b49fc 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -141,20 +141,21 @@ clean: FORCE
 dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
-distclean: dirclean config-clean symlinkclean docclean
+distclean: dirclean config-clean symlinkclean docs/clean
        rm -rf dl
 
 help:
        cat README
 
-doc:
-       $(MAKE) -C docs/ openwrt.pdf
+docs docs/compile: FORCE
+       $(MAKE) -C docs compile
 
-docclean:
-       $(MAKE) -C docs/ clean
+docs/clean: FORCE
+       $(MAKE) -C docs clean
 
 symlinkclean:
        -find package -type l | xargs rm -f
+       rm -rf tmp
 
 .SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;