Add CFE runtime detection
[openwrt/openwrt.git] / Makefile
index 62a03387463aed51e47d3c46ccb9d19928d799df..f6d4fff3aba17a51727064122b5e0681d883dd8a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -20,14 +20,11 @@ all: world
 SHELL:=/usr/bin/env bash
 export LC_ALL=C
 export LANG=C
-export TOPDIR=${shell pwd}
+export TOPDIR=${CURDIR}
 ifeq ($(KBUILD_VERBOSE),99)
   MAKE:=3>/dev/null $(MAKE)
 endif
-ifneq ($(shell tty -s <&3 || echo x),x)
-  IS_TTY=1
-  export IS_TTY
-endif
+export IS_TTY=$(shell tty -s && echo 1 || echo 0)
 
 include $(TOPDIR)/include/verbose.mk
 
@@ -42,46 +39,50 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts Makefile),tmp/.pkginfo)
-  tmp/.pkginfo: FORCE
+ifeq ($(FORCE),)
+  .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
+  world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts Makefile),tmp/.targetinfo)
-  tmp/.targetinfo: FORCE
-endif
+define stamp
+tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile $(5) | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
+endef
 
-ifeq ($(FORCE),)
-  .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
-  world: tmp/.prereq-packages
+STAMP_pkginfo=$(call stamp,pkginfo,package)
+STAMP_targetinfo=$(call stamp,targetinfo,target/linux)
+define scan_info
+
+$(STAMP_$(1)):
+       @mkdir -p tmp/info
+       @rm -f tmp/info/.stamp-$(1)*
+       @touch $$@
+
+$(foreach FILE,$(shell ls $(2)/*/Makefile $(5)),
+tmp/.$(1): $(FILE)
+$(FILE):
+)
+
+ifneq ($(5),)
+tmp/.$(1): $(shell ls $(5))
 endif
 
-tmp/.pkginfo:
-       @mkdir -p tmp
-       @echo Collecting package info...
-       @-for dir in package/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
-               echo; \
-       done > $@
-
-tmp/.targetinfo:
-       @mkdir -p tmp
-       @echo Collecting target info...
-       @-for dir in target/linux/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               ( cd "$$dir"; $(NO_TRACE_MAKE) --no-print-dir DUMP=1 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2 ); \
-               echo; \
-       done > $@
+tmp/.$(1): $(STAMP_$(1)) $(4)
+       @echo -n Collecting $(3) info... 
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)" SCAN_EXTRA="$(5)"
+
+endef
+
+$(eval $(call scan_info,pkginfo,package,package,include/package.mk))
+$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk,target/linux/*/profiles/*.mk))
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -109,10 +110,16 @@ oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
 menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+kernel_menuconfig: .config FORCE
+       -$(MAKE) target/linux-prepare
+       $(NO_TRACE_MAKE) -C target/linux menuconfig
+
+package/%: 
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+target/%:
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
 tools/%: FORCE
@@ -123,6 +130,7 @@ toolchain/%: tmp/.targetinfo FORCE
 
 tmp/.prereq-build: include/prereq-build.mk
        @mkdir -p tmp
+       @rm -f tmp/.host.mk
        @$(NO_TRACE_MAKE) -s -f $(TOPDIR)/include/prereq-build.mk prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
@@ -131,13 +139,23 @@ tmp/.prereq-build: include/prereq-build.mk
 
 tmp/.prereq-packages: include/prereq.mk tmp/.pkginfo .config
        @mkdir -p tmp
+       @rm -f tmp/.host.mk
        @$(NO_TRACE_MAKE) -s -C package prereq 2>/dev/null || { \
                echo "Prerequisite check failed. Use FORCE=1 to override."; \
                false; \
        }
        @touch $@
-       
-prereq: tmp/.prereq-build tmp/.prereq-packages FORCE
+
+tmp/.prereq-target: include/prereq.mk tmp/.targetinfo .config
+       @mkdir -p tmp
+       @rm -f tmp/.host.mk
+       @$(NO_TRACE_MAKE) -s -C target prereq 2>/dev/null || { \
+               echo "Prerequisite check failed. Use FORCE=1 to override."; \
+               false; \
+       }
+       @touch $@
+
+prereq: tmp/.prereq-build tmp/.prereq-packages tmp/.prereq-target FORCE
 
 download: .config FORCE
        $(MAKE) tools/download
@@ -163,7 +181,16 @@ dirclean: clean
 distclean: dirclean config-clean
        rm -rf dl
 
+help:
+       cat README
+
+doc:
+       $(MAKE) -C docs/ openwrt.pdf
+
+docclean:
+       $(MAKE) -C docs/ clean
+
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
-.PHONY: FORCE
+.PHONY: FORCE help
 %: ;