add file type autodetection for the unpack command and nuke PKG_CAT:= in lots of...
[openwrt/openwrt.git] / Makefile
index a3d5720db3b2b0eb7df3e8658c4c77e801da6d70..f6d4fff3aba17a51727064122b5e0681d883dd8a 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -39,53 +39,50 @@ else
 endif
 export OPENWRTVERSION
 
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.pkginfo package scripts include),tmp/.pkginfo)
-  tmp/.pkginfo: FORCE
-endif
-
-ifneq ($(shell ./scripts/timestamp.pl -p tmp/.targetinfo target/linux scripts include),tmp/.targetinfo)
-  tmp/.targetinfo: FORCE
-endif
-
 ifeq ($(FORCE),)
   .config scripts/config/conf scripts/config/mconf: tmp/.prereq-build
   world: tmp/.prereq-packages tmp/.prereq-target
 endif
 
-ifeq ($(IS_TTY),1)
-  define progress
-       printf "\033[M\r$(1)" >&2;
-  endef
+define stamp
+tmp/info/.stamp-$(1)-$(shell ls $(2)/*/Makefile $(5) | (md5sum || md5) 2>/dev/null | cut -d' ' -f1)
+endef
+
+STAMP_pkginfo=$(call stamp,pkginfo,package)
+STAMP_targetinfo=$(call stamp,targetinfo,target/linux)
+define scan_info
+
+$(STAMP_$(1)):
+       @mkdir -p tmp/info
+       @rm -f tmp/info/.stamp-$(1)*
+       @touch $$@
+
+$(foreach FILE,$(shell ls $(2)/*/Makefile $(5)),
+tmp/.$(1): $(FILE)
+$(FILE):
+)
+
+ifneq ($(5),)
+tmp/.$(1): $(shell ls $(5))
 endif
 
-define dumpinfo
-       @mkdir -p tmp
-       @echo -n Collecting $(2) info... 
-       @-for dir in $(1)/*/; do \
-               [ -f "$${dir}/Makefile" ] || continue; \
-               $(call progress,Collecting $(2) info: $${dir%%/}) \
-               echo Source-Makefile: $${dir}Makefile; \
-               $(NO_TRACE_MAKE) --no-print-dir DUMP=1 -C $$dir 3>/dev/null || echo "ERROR: please fix $${dir}Makefile" >&2; \
-               echo; \
-       done > $@
-       @($(call progress,Collecting $(2) info: done))
-       @echo
-endef
+tmp/.$(1): $(STAMP_$(1)) $(4)
+       @echo -n Collecting $(3) info... 
+       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$(1)" SCAN_DIR="$(2)" SCAN_NAME="$(3)" SCAN_DEPS="$(4)" SCAN_EXTRA="$(5)"
 
-tmp/.pkginfo:
-       $(call dumpinfo,package,package)
+endef
 
-tmp/.targetinfo:
-       $(call dumpinfo,target/linux,target)
+$(eval $(call scan_info,pkginfo,package,package,include/package.mk))
+$(eval $(call scan_info,targetinfo,target/linux,target,include/kernel-build.mk include/kernel-version.mk,target/linux/*/profiles/*.mk))
 
 tmpinfo-clean: FORCE
        @-rm -rf tmp/.pkginfo tmp/.targetinfo
 
 tmp/.config.in: tmp/.pkginfo
-       @./scripts/gen_package_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl package_config < $< > $@ || rm -f $@
 
 tmp/.config-target.in: tmp/.targetinfo
-       @./scripts/gen_target_config.pl < $< > $@ || rm -f $@
+       @./scripts/metadata.pl target_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config.in tmp/.config-target.in
        @[ -f .config ] || $(NO_TRACE_MAKE) menuconfig
@@ -113,10 +110,16 @@ oldconfig: scripts/config/conf tmp/.config.in tmp/.config-target.in FORCE
 menuconfig: scripts/config/mconf tmp/.config.in tmp/.config-target.in FORCE
        $< Config.in
 
-package/%: tmp/.pkginfo tmp/.targetinfo FORCE
+kernel_menuconfig: .config FORCE
+       -$(MAKE) target/linux-prepare
+       $(NO_TRACE_MAKE) -C target/linux menuconfig
+
+package/%: 
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C package $(patsubst package/%,%,$@)
 
-target/%: tmp/.pkginfo tmp/.targetinfo FORCE
+target/%:
+       @$(NO_TRACE_MAKE) -s tmp/.pkginfo tmp/.targetinfo
        $(MAKE) -C target $(patsubst target/%,%,$@)
 
 tools/%: FORCE
@@ -187,9 +190,6 @@ doc:
 docclean:
        $(MAKE) -C docs/ clean
 
-symlinks:
-       scripts/feeds.sh $(CONFIG_SOURCE_FEEDS) 
-
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
 .PHONY: FORCE help