mt76: update to the latest version, fixes mt76x2 beacon issue
[openwrt/openwrt.git] / config / Config-images.in
index 5c2e79e41e4f8940c83b1ceec211fe2c32ed1f40..6fa9a67cb644f986a7f207cbf2e366e4062f8462 100644 (file)
@@ -16,6 +16,8 @@ menu "Target Images"
                        prompt "Compression"
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_apm821xx
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_mpc85xx
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        help
@@ -50,6 +52,13 @@ menu "Target Images"
                        help
                          Kernel uses specified external cpio as INITRAMFS_SOURCE.
 
+               config TARGET_INITRAMFS_FORCE
+                        bool "Force"
+                        depends on TARGET_ROOTFS_INITRAMFS
+                        default n
+                        help
+                          Ignore the initramfs passed by the bootloader.
+
        comment "Root filesystem archives"
 
        config TARGET_ROOTFS_CPIOGZ
@@ -72,13 +81,6 @@ menu "Target Images"
                help
                  Build an ext4 root filesystem.
 
-               config TARGET_EXT4_MAXINODE
-                       int "Maximum number of inodes in root filesystem"
-                       depends on TARGET_ROOTFS_EXT4FS
-                       default 6000
-                       help
-                         Select the maximum number of inodes in the root filesystem.
-
                config TARGET_EXT4_RESERVED_PCT
                        int "Percentage of reserved blocks in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
@@ -126,7 +128,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_JFFS2
                bool "jffs2"
-               default y if USES_JFFS2
+               depends on USES_JFFS2
                help
                  Build a JFFS2 root filesystem.
 
@@ -147,6 +149,7 @@ menu "Target Images"
                        int "Block size (in KiB)"
                        depends on TARGET_ROOTFS_SQUASHFS
                        default 64 if LOW_MEMORY_FOOTPRINT
+                       default 1024 if (SMALL_FLASH && !LOW_MEMORY_FOOTPRINT)
                        default 256
 
        menuconfig TARGET_ROOTFS_UBIFS
@@ -186,7 +189,7 @@ menu "Target Images"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
-               depends on TARGET_x86_64 || (TARGET_x86 && !(TARGET_x86_olpc || TARGET_x86_rdc))
+               depends on TARGET_x86
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                default y
@@ -206,10 +209,13 @@ menu "Target Images"
        config GRUB_BAUDRATE
                int "Serial port baud rate"
                depends on GRUB_IMAGES
-               default 19200 if TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501
-               default 38400 if TARGET_x86_alix2
-               default 115200 if TARGET_x86_geos || TARGET_x86_kvm_guest
-               default 38400
+               default 38400 if TARGET_x86_generic
+               default 115200
+
+       config GRUB_FLOWCONTROL
+               bool "Use RTE/CTS on serial console"
+               depends on GRUB_SERIAL != ""
+               default n
 
        config GRUB_BOOTOPTS
                string "Extra kernel boot options"
@@ -225,6 +231,14 @@ menu "Target Images"
                help
                  If you don't know, 5 seconds is a reasonable default.
 
+       config GRUB_TITLE
+               string "Title for the menu entry in GRUB"
+               depends on GRUB_IMAGES
+               default "OpenWrt"
+               help
+                 This is the title of the GRUB menu entry.
+                 If unspecified, it defaults to OpenWrt.
+
        config VDI_IMAGES
                bool "Build VirtualBox image files (VDI)"
                depends on TARGET_x86 || TARGET_x86_64
@@ -241,11 +255,11 @@ menu "Target Images"
 
        config TARGET_IMAGES_PAD
                bool "Pad images to filesystem size (for JFFS2)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
+               depends on GRUB_IMAGES
 
        config TARGET_IMAGES_GZIP
                bool "GZip images"
-               depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS
+               depends on TARGET_IMAGES_PAD || TARGET_ROOTFS_EXT4FS || TARGET_x86
                default y
 
        comment "Image Options"
@@ -254,65 +268,22 @@ menu "Target Images"
 
        config TARGET_KERNEL_PARTSIZE
                int "Kernel partition size (in MB)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-               default 4
+               depends on GRUB_IMAGES || USES_BOOT_PART
+               default 16
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MB)"
-               depends on GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
-               default 48
+               depends on GRUB_IMAGES || USES_ROOTFS_PART || TARGET_ROOTFS_EXT4FS || TARGET_mvebu || TARGET_rb532 || TARGET_sunxi || TARGET_uml
+               default 256
                help
                  Select the root filesystem partition size.
 
        config TARGET_ROOTFS_PARTNAME
                string "Root partition on target device"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-               default "/dev/xvda2" if TARGET_x86_xen_domu
-               default "/dev/sda2" if TARGET_x86 && ! TARGET_x86_xen_domu
+               depends on GRUB_IMAGES
                help
                  Override the root partition on the final device. If left empty,
                  it will be mounted by PARTUUID which makes the kernel find the
                  appropriate disk automatically.
 
-
-       menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
-               bool "Include kernel in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
-               default n
-               help
-                 Include the kernel image in the rootfs. Typically, the image is placed
-                 below /boot.
-
-               config TARGET_ROOTFS_INCLUDE_UIMAGE
-                       bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_ZIMAGE
-                       bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_FIT
-                       bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-       config TARGET_ROOTFS_INCLUDE_DTB
-               bool "Include DTB in root filesystem"
-               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
-               default n
-               help
-                 Include the device tree blob file(s) in the rootfs. Typically the DTBs
-                 are placed below /boot.
-
 endmenu