base-files: allocate uid/gid starting from 65536
[openwrt/openwrt.git] / config / Config-images.in
index 39e51e4c6eeb5be7057dee70edb57410fb38b849..95752f737ad013a296afb5e7b28278a16b73b27d 100644 (file)
@@ -10,12 +10,13 @@ menu "Target Images"
                bool "ramdisk"
                default y if USES_INITRAMFS
                help
-                 Embed the rootfs into the kernel (initramfs)
+                 Embed the root filesystem into the kernel (initramfs).
 
                choice
                        prompt "Compression"
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_apm821xx
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        help
@@ -48,7 +49,7 @@ menu "Target Images"
                        prompt "Use external cpio" if TARGET_ROOTFS_INITRAMFS
                        default ""
                        help
-                         Kernel uses specified external cpio as INITRAMFS_SOURCE
+                         Kernel uses specified external cpio as INITRAMFS_SOURCE.
 
        comment "Root filesystem archives"
 
@@ -56,13 +57,13 @@ menu "Target Images"
                bool "cpio.gz"
                default y if USES_CPIOGZ
                help
-                 Build a compressed cpio archive of the the root filesystem
+                 Build a compressed cpio archive of the root filesystem.
 
        config TARGET_ROOTFS_TARGZ
                bool "tar.gz"
                default y if USES_TARGZ
                help
-                 Build a compressed tar archive of the the root filesystem
+                 Build a compressed tar archive of the root filesystem.
 
        comment "Root filesystem images"
 
@@ -70,28 +71,21 @@ menu "Target Images"
                bool "ext4"
                default y if USES_EXT4
                help
-                 Build a ext4 root filesystem
-
-               config TARGET_EXT4_MAXINODE
-                       int "Maximum number of inodes in root filesystem"
-                       depends on TARGET_ROOTFS_EXT4FS
-                       default 6000
-                       help
-                         Allows you to change the maximum number of inodes in the root filesystem
+                 Build an ext4 root filesystem.
 
                config TARGET_EXT4_RESERVED_PCT
                        int "Percentage of reserved blocks in root filesystem"
                        depends on TARGET_ROOTFS_EXT4FS
                        default 0
                        help
-                         Allows you to change the percentage of reserved blocks in the root filesystem
+                         Select the percentage of reserved blocks in the root filesystem.
 
                choice
                        prompt "Root filesystem block size"
                        default TARGET_EXT4_BLOCKSIZE_4K
                        depends on TARGET_ROOTFS_EXT4FS
                        help
-                         Allows you to change the block size of the root filesystem
+                         Select the block size of the root filesystem.
 
                        config TARGET_EXT4_BLOCKSIZE_4K
                                bool "4k"
@@ -115,33 +109,33 @@ menu "Target Images"
                        depends on TARGET_ROOTFS_EXT4FS
                        default n
                        help
-                         Create an ext4 filesystem with a journal
+                         Create an ext4 filesystem with a journal.
 
        config TARGET_ROOTFS_ISO
                bool "iso"
                default n
                depends on TARGET_x86_generic
                help
-                 Create some bootable ISO image
+                 Create a bootable ISO image.
 
        config TARGET_ROOTFS_JFFS2
                bool "jffs2"
-               default y if USES_JFFS2
+               depends on USES_JFFS2
                help
-                 Build a jffs2 root filesystem
+                 Build a JFFS2 root filesystem.
 
        config TARGET_ROOTFS_JFFS2_NAND
                bool "jffs2 for NAND"
                default y if USES_JFFS2_NAND
                depends on USES_JFFS2_NAND
                help
-                 Build a jffs2 root filesystem for NAND flash
+                 Build a JFFS2 root filesystem for NAND flash.
 
        menuconfig TARGET_ROOTFS_SQUASHFS
                bool "squashfs"
                default y if USES_SQUASHFS
                help
-                 Build a squashfs-lzma root filesystem
+                 Build a squashfs-lzma root filesystem.
 
                config TARGET_SQUASHFS_BLOCK_SIZE
                        int "Block size (in KiB)"
@@ -154,7 +148,7 @@ menu "Target Images"
                default y if USES_UBIFS
                depends on USES_UBIFS
                help
-                 Build a ubifs root filesystem
+                 Build a UBIFS root filesystem.
 
                choice
                        prompt "compression"
@@ -177,7 +171,7 @@ menu "Target Images"
                        bool "free space fixup" if TARGET_ROOTFS_UBIFS
                        default y
                        help
-                         The file-system free space has to be fixed up on first mount
+                         The filesystem free space has to be fixed up on first mount.
 
                config TARGET_UBIFS_JOURNAL_SIZE
                        string
@@ -186,7 +180,7 @@ menu "Target Images"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
-               depends on TARGET_x86_64 || (TARGET_x86 && !(TARGET_x86_olpc || TARGET_x86_rdc))
+               depends on TARGET_x86
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                default y
@@ -206,10 +200,13 @@ menu "Target Images"
        config GRUB_BAUDRATE
                int "Serial port baud rate"
                depends on GRUB_IMAGES
-               default 19200 if TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501
-               default 38400 if TARGET_x86_alix2
-               default 115200 if TARGET_x86_geos || TARGET_x86_kvm_guest
-               default 38400
+               default 38400 if TARGET_x86_generic
+               default 115200
+
+       config GRUB_FLOWCONTROL
+               bool "Use RTE/CTS on serial console"
+               depends on GRUB_SERIAL != ""
+               default n
 
        config GRUB_BOOTOPTS
                string "Extra kernel boot options"
@@ -241,7 +238,7 @@ menu "Target Images"
 
        config TARGET_IMAGES_PAD
                bool "Pad images to filesystem size (for JFFS2)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
+               depends on GRUB_IMAGES
 
        config TARGET_IMAGES_GZIP
                bool "GZip images"
@@ -254,64 +251,22 @@ menu "Target Images"
 
        config TARGET_KERNEL_PARTSIZE
                int "Kernel partition size (in MB)"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-               default 4
+               depends on GRUB_IMAGES
+               default 16
 
        config TARGET_ROOTFS_PARTSIZE
                int "Root filesystem partition size (in MB)"
-               depends on GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532
-               default 48
+               depends on GRUB_IMAGES || TARGET_ROOTFS_EXT4FS || TARGET_rb532 || TARGET_mvebu || TARGET_uml
+               default 256
                help
-                 Allows you to change the root filesystem partition size
+                 Select the root filesystem partition size.
 
        config TARGET_ROOTFS_PARTNAME
                string "Root partition on target device"
-               depends on OLPC_BOOTSCRIPT_IMAGES || GRUB_IMAGES
-               default "/dev/xvda2" if TARGET_x86_xen_domu
-               default "/dev/sda2" if ! TARGET_x86_xen_domu
-               help
-                 The root partition on the final device.  If you don't know,
-                 you probably want the default (/dev/sda2).
-
-
-       menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
-               bool "Include kernel in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
-               default n
-               help
-                 Include the kernel image in the rootfs. Typically the image is placed
-                 below /boot.
-
-               config TARGET_ROOTFS_INCLUDE_UIMAGE
-                       bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_ZIMAGE
-                       bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_FIT
-                       bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-       config TARGET_ROOTFS_INCLUDE_DTB
-               bool "Include DTB in root filesystem"
-               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
-               default n
+               depends on GRUB_IMAGES
                help
-                 Include the device tree blob file(s) in the rootfs. Typically the DTBs
-                 are placed below /boot.
+                 Override the root partition on the final device. If left empty,
+                 it will be mounted by PARTUUID which makes the kernel find the
+                 appropriate disk automatically.
 
 endmenu