image: make mkfs template output to $@
[openwrt/openwrt.git] / config / Config-images.in
index a563b38dd6d06069723e851bbab1c2ca3bfa9f0e..b73442d6f629ce4dd056b39abbbd525f2da6fabe 100644 (file)
@@ -16,6 +16,7 @@ menu "Target Images"
                        prompt "Compression"
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ar71xx
                        default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_ramips
+                       default TARGET_INITRAMFS_COMPRESSION_LZMA if TARGET_apm821xx
                        default TARGET_INITRAMFS_COMPRESSION_NONE
                        depends on TARGET_ROOTFS_INITRAMFS
                        help
@@ -126,7 +127,7 @@ menu "Target Images"
 
        config TARGET_ROOTFS_JFFS2
                bool "jffs2"
-               default y if USES_JFFS2
+               depends on USES_JFFS2
                help
                  Build a JFFS2 root filesystem.
 
@@ -186,7 +187,7 @@ menu "Target Images"
 
        config GRUB_IMAGES
                bool "Build GRUB images (Linux x86 or x86_64 host only)"
-               depends on TARGET_x86_64 || (TARGET_x86 && !TARGET_x86_rdc)
+               depends on TARGET_x86
                depends on TARGET_ROOTFS_EXT4FS || TARGET_ROOTFS_ISO || TARGET_ROOTFS_JFFS2 || TARGET_ROOTFS_SQUASHFS
                select PACKAGE_grub2
                default y
@@ -206,10 +207,9 @@ menu "Target Images"
        config GRUB_BAUDRATE
                int "Serial port baud rate"
                depends on GRUB_IMAGES
-               default 19200 if TARGET_x86_generic_Soekris45xx || TARGET_x86_generic_Soekris48xx || TARGET_x86_net5501
-               default 38400 if TARGET_x86_alix2
-               default 115200 if TARGET_x86_geos || TARGET_x86_kvm_guest
-               default 38400
+               default 38400 if TARGET_x86_generic
+               default 38400 if TARGET_x86_geode
+               default 115200
 
        config GRUB_BOOTOPTS
                string "Extra kernel boot options"
@@ -272,45 +272,4 @@ menu "Target Images"
                  it will be mounted by PARTUUID which makes the kernel find the
                  appropriate disk automatically.
 
-
-       menuconfig TARGET_ROOTFS_INCLUDE_KERNEL
-               bool "Include kernel in root filesystem"
-               depends on TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS
-               default n
-               help
-                 Include the kernel image in the rootfs. Typically, the image is placed
-                 below /boot.
-
-               config TARGET_ROOTFS_INCLUDE_UIMAGE
-                       bool "include uImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_ZIMAGE
-                       bool "include zImage" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-               config TARGET_ROOTFS_INCLUDE_FIT
-                       bool "include FIT" if TARGET_ROOTFS_INCLUDE_KERNEL
-                       default y
-                       help
-                         This option might not apply to all targets. Make sure
-                         to check target/linux/<your_target>/image/Makefile to
-                         see if this option will have any effect.
-
-       config TARGET_ROOTFS_INCLUDE_DTB
-               bool "Include DTB in root filesystem"
-               depends on USES_DEVICETREE && (TARGET_ROOTFS_UBIFS || TARGET_ROOTFS_EXT4FS)
-               default n
-               help
-                 Include the device tree blob file(s) in the rootfs. Typically the DTBs
-                 are placed below /boot.
-
 endmenu