generate package for the new IXP4xx crpyto driver
[openwrt/openwrt.git] / docs / Makefile
index 8c3ca646ddf757b967c0ba7f7111f89fc31616bb..8bae4625af991c77ad6b1ab6303a6383b493526f 100644 (file)
@@ -1,15 +1,48 @@
-openwrt.pdf: Makefile openwrt.tex config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
-       $(MAKE) cleanup
-       pdflatex openwrt.tex
-       pdflatex openwrt.tex
-       $(MAKE) cleanup
-       
+ifeq ($(TOPDIR),)
+  TOPDIR:=${CURDIR}/..
+endif
+PKG_NAME=docs
+
+all: compile
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/prereq.mk
+
+MAIN = openwrt.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
+
+compile: $(TMP_DIR)/.prereq-docs
+       $(NO_TRACE_MAKE) cleanup
+       latex $(MAIN)
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
+
+$(TMP_DIR)/.prereq-docs:
+       mkdir -p $(TMP_DIR)
+       $(NO_TRACE_MAKE) prereq
+       touch $@
+
+openwrt.html: $(DEPS)
+       htlatex $(MAIN)
+
+openwrt.pdf: $(DEPS)
+       pdflatex $(MAIN)
+
 clean: cleanup
-       rm -f openwrt.pdf
+       rm -f openwrt.pdf openwrt.html openwrt.css
 
 cleanup: FORCE
-       rm -f *.log *.aux *.toc *.out
+       rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
+$(eval $(call RequireCommand,latex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,pdflatex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,htlatex, \
+       You need to install tex4ht to build the OpenWrt documentation \
+))
 
 FORCE:
 .PHONY: FORCE