Document how to build binary ipkgs
[openwrt/openwrt.git] / docs / Makefile
index 9e888a4af2df7fab545631ffe872b16106738ffb..a7fe08e50571828341d7a16084a5a7bdfe3f5d26 100644 (file)
@@ -1,21 +1,25 @@
 ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
+PKG_NAME=docs
+
+all: compile
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex .prereq
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-all:
-       $(MAKE) cleanup
+compile: $(TMP_DIR)/.prereq-docs
+       $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
-       $(MAKE) openwrt.pdf openwrt.html
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
 
-.prereq:
-       $(MAKE) prereq
+$(TMP_DIR)/.prereq-docs:
+       mkdir -p $(TMP_DIR)
+       $(NO_TRACE_MAKE) prereq
        touch $@
 
 openwrt.html: $(DEPS)
@@ -23,16 +27,19 @@ openwrt.html: $(DEPS)
 
 openwrt.pdf: $(DEPS)
        pdflatex $(MAIN)
-       
+
 clean: cleanup
        rm -f openwrt.pdf openwrt.html openwrt.css
 
 cleanup: FORCE
        rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
-$(eval $(call RequireCommand,pdflatex, \
+$(eval $(call RequireCommand,latex, \
        You need to install LaTeX to build the OpenWrt documentation \
 ))
+$(eval $(call RequireCommand,pdflatex, \
+       You need to install PDFLaTeX to build the OpenWrt documentation \
+))
 $(eval $(call RequireCommand,htlatex, \
        You need to install tex4ht to build the OpenWrt documentation \
 ))