apply latex style patch posted on openwrt-devel@lists
[openwrt/openwrt.git] / docs / Makefile
index 359f4e63080dcfaf10a3fae2a5bb3c1a8eeb38dc..f6caa826030da721a568ac5efef0eed87b18cabe 100644 (file)
@@ -1,11 +1,24 @@
+ifeq ($(TOPDIR),)
+  TOPDIR:=${CURDIR}/..
+endif
+
+all: compile
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/prereq.mk
+
 MAIN = openwrt.tex
-DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex
+DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-all:
-       $(MAKE) cleanup
+compile:
+       $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
-       $(MAKE) openwrt.pdf openwrt.html
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
+
+$(TMP_DIR)/.prereq-docs:
+       $(NO_TRACE_MAKE) prereq
+       touch $@
 
 openwrt.html: $(DEPS)
        htlatex $(MAIN)
@@ -19,6 +32,15 @@ clean: cleanup
 cleanup: FORCE
        rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
+$(eval $(call RequireCommand,latex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,pdflatex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
+$(eval $(call RequireCommand,htlatex, \
+       You need to install tex4ht to build the OpenWrt documentation \
+))
 
 FORCE:
 .PHONY: FORCE