fix a few overfull hboxes, remove some redundant stuff
[openwrt/openwrt.git] / docs / Makefile
index d20556a67b349744c7ad15d0f63cfaae2dbe1f78..f6caa826030da721a568ac5efef0eed87b18cabe 100644 (file)
@@ -2,20 +2,22 @@ ifeq ($(TOPDIR),)
   TOPDIR:=${CURDIR}/..
 endif
 
+all: compile
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/prereq.mk
 
 MAIN = openwrt.tex
 DEPS = $(MAIN) Makefile config.tex network.tex network-scripts.tex network-scripts.tex wireless.tex build.tex adding.tex bugs.tex $(TMP_DIR)/.prereq-docs
 
-all:
-       $(MAKE) cleanup
+compile:
+       $(NO_TRACE_MAKE) cleanup
        latex $(MAIN)
-       $(MAKE) openwrt.pdf openwrt.html
-       $(MAKE) cleanup
+       $(NO_TRACE_MAKE) openwrt.pdf openwrt.html
+       $(NO_TRACE_MAKE) cleanup
 
 $(TMP_DIR)/.prereq-docs:
-       $(MAKE) prereq
+       $(NO_TRACE_MAKE) prereq
        touch $@
 
 openwrt.html: $(DEPS)
@@ -30,6 +32,9 @@ clean: cleanup
 cleanup: FORCE
        rm -f *.log *.aux *.toc *.out *.lg *.dvi *.idv *.4ct *.4tc *.xref *.tmp *.dvi
 
+$(eval $(call RequireCommand,latex, \
+       You need to install LaTeX to build the OpenWrt documentation \
+))
 $(eval $(call RequireCommand,pdflatex, \
        You need to install LaTeX to build the OpenWrt documentation \
 ))