uclient: update to the latest version with better help and DELETE
[openwrt/openwrt.git] / docs / adding.tex
index 97547ac859458ba58361b9be0e85fba62ecb9e9c..7b80c0d1d6d20d728044e542bd27bcebe68ddf08 100644 (file)
@@ -556,7 +556,7 @@ include $(INCLUDE_DIR)/image.mk
 
 define Image/BuildKernel
         cp $(KDIR)/vmlinux.elf $(BIN_DIR)/openwrt-$(BOARD)-vmlinux.elf
-        gzip -9 -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
+        gzip -9n -c $(KDIR)/vmlinux > $(KDIR)/vmlinux.bin.gz
         $(STAGING_DIR_HOST)/bin/lzma e $(KDIR)/vmlinux $(KDIR)/vmlinux.bin.l7
         dd if=$(KDIR)/vmlinux.bin.l7 of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.lzma bs=65536 conv=sync
         dd if=$(KDIR)/vmlinux.bin.gz of=$(BIN_DIR)/openwrt-$(BOARD)-vmlinux.gz bs=65536 conv=sync