uclient: update to the latest version with better help and DELETE
[openwrt/openwrt.git] / docs / build.tex
index 493be127c6f485bbe18561757b229b3b57515e76..6e1539acf2d2be0609ea3eabfec788b46c06e045 100644 (file)
@@ -41,11 +41,10 @@ So let's take a look at OpenWrt and see how this all works.
 
 \subsubsection{Download OpenWrt}
 
-This article refers to the "Kamikaze" branch of OpenWrt, which can be downloaded via
-subversion using the following command:
+OpenWrt can be downloaded via subversion using the following command:
 
 \begin{Verbatim}
-$ svn checkout https://svn.openwrt.org/openwrt/trunk kamikaze
+$ svn checkout svn://svn.openwrt.org/openwrt/trunk openwrt-trunk
 \end{Verbatim}
 
 Additionally, there is a trac interface on \href{https://dev.openwrt.org/}{https://dev.openwrt.org/}
@@ -88,7 +87,7 @@ $ ./scripts/feeds update
 
 Those packages can be used to extend the functionality of the build system and need to be
 symlinked into the main trunk. Once you do that, the packages will show up in the menu for
-configuration. From kamikaze you would do something like this:
+configuration. You would do something like this:
 
 \begin{Verbatim}
 $ ./scripts/feeds search nmap
@@ -182,7 +181,7 @@ and packages will be in the "\texttt{bin/packages}" directory.
 
 One of the things that we've attempted to do with OpenWrt's template system is make it
 incredibly easy to port software to OpenWrt. If you look at a typical package directory
-in OpenWrt you'll find two things:
+in OpenWrt you'll find several things:
 
 \begin{itemize}
     \item \texttt{package/\textit{<name>}/Makefile}
@@ -204,7 +203,6 @@ simplifies the entire ordeal.
 Here for example, is \texttt{package/bridge/Makefile}:
 
 \begin{Verbatim}[frame=single,numbers=left]
-# $Id: Makefile 5624 2006-11-23 00:29:07Z nbd $
 
 include $(TOPDIR)/rules.mk
 
@@ -294,7 +292,7 @@ directly as the Nth argument to \texttt{BuildPackage}.
 
     \begin{itemize}
         \item \texttt{SECTION} \\
-            The type of package (currently unused)
+            The section of package (currently unused)
         \item \texttt{CATEGORY} \\
             Which menu it appears in menuconfig: Network, Sound, Utilities, Multimedia ...
         \item \texttt{TITLE} \\
@@ -394,7 +392,6 @@ To do so, you can use the following template, which basically sets to nothing th
 Compile templates.
 
 \begin{Verbatim}[frame=single,numbers=left]
-# $Id: $
 
 include $(TOPDIR)/rules.mk
 
@@ -451,7 +448,6 @@ For external kernel modules, you can add them to the build system just like if t
 Here for instance the Makefile for the I2C subsytem kernel modules :
 
 \begin{Verbatim}[frame=single,numbers=left]
-# $Id $
 
 I2CMENU:=I2C Bus