ar71xx: fix Arduino Yun enabling of level shifters outputs
[openwrt/openwrt.git] / include / autotools.mk
index 1472b5a781edc5e3a91985185c2aa87b5a666288..aa044aa0b4e516e85e5c65ab2e5372b96b010573 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -36,14 +36,14 @@ define autoreconf
                $(foreach p,$(3), \
                        if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
-                               touch NEWS AUTHORS COPYING ChangeLog; \
+                               [ -e $(p)/config.rpath ] || \
+                                               ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath; \
+                               touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
                                $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
                                        $(if $(word 2,$(3)),--no-recursive) \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
                                        $(patsubst %,-I %,$(5)) \
-                                       $(patsubst %,-I %,$(4)) $(4) || true; \
-                               [ -e $(p)/config.rpath ] || \
-                                               ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath;
+                                       $(patsubst %,-I %,$(4)) $(p) || true; \
                        fi; \
                ) \
        );
@@ -51,12 +51,12 @@ endef
 
 # 1: build dir
 define patch_libtool
-       (cd $(1); \
+       @(cd $(1); \
                for lt in $$$$($$(STAGING_DIR_HOST)/bin/find . -name ltmain.sh); do \
-                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION=\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
+                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION="\?\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
                        case "$$$$lt_version" in \
                                1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
-                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch) ;; \
+                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \
                                *) echo "autotools.mk: error: Unsupported libtool version v$$$$lt_version - cannot patch $$$$lt"; exit 1 ;; \
                        esac; \
                done; \
@@ -75,7 +75,7 @@ define autoreconf_target
   $(strip $(call autoreconf, \
     $(PKG_BUILD_DIR), $(PKG_REMOVE_FILES), \
     $(PKG_AUTOMAKE_PATHS), $(PKG_LIBTOOL_PATHS), \
-    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
+    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR_HOSTPKG)/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
 endef
 
 define patch_libtool_target
@@ -83,19 +83,36 @@ define patch_libtool_target
     $(PKG_BUILD_DIR)))
 endef
 
+define gettext_version_target
+       (cd $(PKG_BUILD_DIR) && \
+               GETTEXT_VERSION=$(shell $(STAGING_DIR_HOSTPKG)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.*\([0-9]\.[0-9]\{2\}\.[0-9]\).*/\1/p' ) && \
+               $(STAGING_DIR_HOST)/bin/sed \
+                       -i $(PKG_BUILD_DIR)/configure.ac \
+                       -e "s/AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+               $(STAGING_DIR_HOSTPKG)/bin/autopoint --force \
+       );
+endef
+
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += gettext_version_target
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf_target
+ endif
+endif
+
 ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += patch_libtool_target
 endif
 
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool libintl libiconv
+  PKG_BUILD_DEPENDS += libtool gettext libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool libintl libiconv
+  PKG_BUILD_DEPENDS += libtool gettext libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif