Revert "dnsmasq: follow upstream dnsmasq pre-v2.81"
[openwrt/openwrt.git] / include / autotools.mk
index 2ab42df61fff471f4b1e905209bee0845b8361f5..aa044aa0b4e516e85e5c65ab2e5372b96b010573 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2010 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -13,6 +13,18 @@ define libtool_remove_files
        find $(1) -name '*.la' | $(XARGS) rm -f;
 endef
 
+
+AM_TOOL_PATHS:= \
+       AUTOM4TE=$(STAGING_DIR_HOST)/bin/autom4te \
+       AUTOCONF=$(STAGING_DIR_HOST)/bin/autoconf \
+       AUTOMAKE=$(STAGING_DIR_HOST)/bin/automake \
+       ACLOCAL=$(STAGING_DIR_HOST)/bin/aclocal \
+       AUTOHEADER=$(STAGING_DIR_HOST)/bin/autoheader \
+       LIBTOOLIZE=$(STAGING_DIR_HOST)/bin/libtoolize \
+       LIBTOOL=$(STAGING_DIR_HOST)/bin/libtool \
+       M4=$(STAGING_DIR_HOST)/bin/m4 \
+       AUTOPOINT=true
+
 # 1: build dir
 # 2: remove files
 # 3: automake paths
@@ -22,23 +34,39 @@ define autoreconf
        (cd $(1); \
                $(patsubst %,rm -f %;,$(2)) \
                $(foreach p,$(3), \
-                       if [ -x $(p)/autogen.sh ]; then \
-                               $(p)/autogen.sh || true; \
-                       elif [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
-                               [ -f $(p)/aclocal.m4 ] && [ ! -f $(p)/acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
+                       if [ -f $(p)/configure.ac ] || [ -f $(p)/configure.in ]; then \
                                [ -d $(p)/autom4te.cache ] && rm -rf autom4te.cache; \
-                               $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               [ -e $(p)/config.rpath ] || \
+                                               ln -s $(SCRIPT_DIR)/config.rpath $(p)/config.rpath; \
+                               touch NEWS AUTHORS COPYING ABOUT-NLS ChangeLog; \
+                               $(AM_TOOL_PATHS) $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                                       $(if $(word 2,$(3)),--no-recursive) \
                                        -B $(STAGING_DIR_HOST)/share/aclocal \
-                                       $(patsubst %,-B %,$(5)) \
-                                       $(patsubst %,-I %,$(4)) $(4) || true; \
+                                       $(patsubst %,-I %,$(5)) \
+                                       $(patsubst %,-I %,$(4)) $(p) || true; \
                        fi; \
                ) \
        );
 endef
 
+# 1: build dir
+define patch_libtool
+       @(cd $(1); \
+               for lt in $$$$($$(STAGING_DIR_HOST)/bin/find . -name ltmain.sh); do \
+                       lt_version="$$$$($$(STAGING_DIR_HOST)/bin/sed -ne 's,^[[:space:]]*VERSION="\?\([0-9]\.[0-9]\+\).*,\1,p' $$$$lt)"; \
+                       case "$$$$lt_version" in \
+                               1.5|2.2|2.4) echo "autotools.mk: Found libtool v$$$$lt_version - applying patch to $$$$lt"; \
+                                       (cd $$$$(dirname $$$$lt) && $$(PATCH) -N -s -p1 < $$(TOPDIR)/tools/libtool/files/libtool-v$$$$lt_version.patch || true) ;; \
+                               *) echo "autotools.mk: error: Unsupported libtool version v$$$$lt_version - cannot patch $$$$lt"; exit 1 ;; \
+                       esac; \
+               done; \
+       );
+endef
+
 
 PKG_LIBTOOL_PATHS?=$(CONFIGURE_PATH)
 PKG_AUTOMAKE_PATHS?=$(CONFIGURE_PATH)
+PKG_MACRO_PATHS?=m4
 PKG_REMOVE_FILES?=aclocal.m4
 
 Hooks/InstallDev/Post += libtool_remove_files
@@ -47,18 +75,44 @@ define autoreconf_target
   $(strip $(call autoreconf, \
     $(PKG_BUILD_DIR), $(PKG_REMOVE_FILES), \
     $(PKG_AUTOMAKE_PATHS), $(PKG_LIBTOOL_PATHS), \
-    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR)/usr/share/aclocal))
+    $(STAGING_DIR)/host/share/aclocal $(STAGING_DIR_HOSTPKG)/share/aclocal $(STAGING_DIR)/usr/share/aclocal $(PKG_MACRO_PATHS)))
 endef
 
+define patch_libtool_target
+  $(strip $(call patch_libtool, \
+    $(PKG_BUILD_DIR)))
+endef
+
+define gettext_version_target
+       (cd $(PKG_BUILD_DIR) && \
+               GETTEXT_VERSION=$(shell $(STAGING_DIR_HOSTPKG)/bin/gettext -V | $(STAGING_DIR_HOST)/bin/sed -ne '1s/.*\([0-9]\.[0-9]\{2\}\.[0-9]\).*/\1/p' ) && \
+               $(STAGING_DIR_HOST)/bin/sed \
+                       -i $(PKG_BUILD_DIR)/configure.ac \
+                       -e "s/AM_GNU_GETTEXT_VERSION(.*)/AM_GNU_GETTEXT_VERSION(\[$$$$GETTEXT_VERSION\])/g" && \
+               $(STAGING_DIR_HOSTPKG)/bin/autopoint --force \
+       );
+endef
+
+ifneq ($(filter gettext-version,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += gettext_version_target
+ ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += autoreconf_target
+ endif
+endif
+
+ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
+  Hooks/Configure/Pre += patch_libtool_target
+endif
+
 ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool gettext libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
+  PKG_BUILD_DEPENDS += libtool gettext libiconv
  ifeq ($(filter no-autoreconf,$(PKG_FIXUP)),)
   Hooks/Configure/Pre += autoreconf_target
  endif
@@ -74,23 +128,36 @@ endif
 HOST_FIXUP?=$(PKG_FIXUP)
 HOST_LIBTOOL_PATHS?=$(if $(PKG_LIBTOOL_PATHS),$(PKG_LIBTOOL_PATHS),.)
 HOST_AUTOMAKE_PATHS?=$(if $(PKG_AUTOMAKE_PATHS),$(PKG_AUTOMAKE_PATHS),.)
+HOST_MACRO_PATHS?=$(if $(PKG_MACRO_PATHS),$(PKG_MACRO_PATHS),m4)
 HOST_REMOVE_FILES?=$(PKG_REMOVE_FILES)
 
 define autoreconf_host
   $(strip $(call autoreconf, \
     $(HOST_BUILD_DIR), $(HOST_REMOVE_FILES), \
-    $(HOST_AUTOMAKE_PATHS), $(HOST_LIBTOOL_PATHS)))
+    $(HOST_AUTOMAKE_PATHS), $(HOST_LIBTOOL_PATHS), \
+    $(HOST_MACRO_PATHS)))
 endef
 
+define patch_libtool_host
+  $(strip $(call patch_libtool, \
+    $(HOST_BUILD_DIR)))
+endef
+
+ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
+  Hooks/HostConfigure/Pre += patch_libtool_host
+endif
+
+ifneq ($(filter patch-libtool,$(HOST_FIXUP)),)
+  Hooks/HostConfigure/Pre += $(strip $(call patch_libtool,$(HOST_BUILD_DIR)))
+endif
+
 ifneq ($(filter libtool,$(HOST_FIXUP)),)
-  HOST_BUILD_DEPENDS += libtool
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif
 endif
 
 ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
-  HOST_BUILD_DEPENDS += libtool
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif