include/cmake.mk: Add helper macro to handle conditionals for CMake boolean type...
[openwrt/openwrt.git] / include / cmake.mk
index a15cf3a671f49209f7e330d8d1c990c88ae8c3e7..009c6c27728e52eec7131952149232bfa7e60168 100644 (file)
@@ -1,3 +1,5 @@
+cmake_bool = $(patsubst %,-D%:BOOL=$(if $($(1)),ON,OFF),$(2))
+
 PKG_INSTALL:=1
 
 ifneq ($(findstring c,$(OPENWRT_VERBOSE)),)