ar71xx: fix Arduino Yun enabling of level shifters outputs
[openwrt/openwrt.git] / include / debug.mk
index 73e61790602f8dbc30fde0da97a57bcba74651ce..59a99c0f77d89e22b12e93eec168b7cd0341165a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # d: show subdirectory tree
 # t: show added targets
 # l: show legacy targets
+# r: show autorebuild messages
 # v: verbose (no .SILENCE for common targets)
 
-ifeq ($(DEBUG),all)
-  build_debug:=dltv
-else
-  build_debug:=$(DEBUG)
+ifeq ($(DUMP),)
+  ifeq ($(DEBUG),all)
+    build_debug:=dltvr
+  else
+    build_debug:=$(DEBUG)
+  endif
 endif
 
+ifneq ($(DEBUG),)
+
 define debug
-$$(findstring $(2),$$(if $$(DEBUG_DIR),$$(if $$(filter $$(DEBUG_DIR)%,$(1)),$(build_debug)),$(build_debug)))
+$$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
 endef
 
 define warn
 $$(if $(call debug,$(1),$(2)),$$(warning $(3)))
 endef
 
+define debug_eval
+$$(if $(call debug,$(1),$(2)),$(3))
+endef
+
 define warn_eval
 $(call warn,$(1),$(2),$(3)     $(4))
 $(4)
 endef
 
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif