image.mk: force rebuild of kernel dependent parts - fixes auto-rebuild on DTS changes
[openwrt/openwrt.git] / include / debug.mk
index faead042dc4a81909cef3689b94f9a11b367ad74..59a99c0f77d89e22b12e93eec168b7cd0341165a 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -21,6 +21,8 @@ ifeq ($(DUMP),)
   endif
 endif
 
+ifneq ($(DEBUG),)
+
 define debug
 $$(findstring $(2),$$(if $$(DEBUG_SCOPE_DIR),$$(if $$(filter $$(DEBUG_SCOPE_DIR)%,$(1)),$(build_debug)),$(build_debug)))
 endef
@@ -38,4 +40,12 @@ $(call warn,$(1),$(2),$(3)   $(4))
 $(4)
 endef
 
+else
+
+debug:=
+warn:=
+debug_eval:=
+warn_eval = $(4)
+
+endif