refresh atheros config, add missing symbols to generic 2.6.26 config
[openwrt/openwrt.git] / include / debug.mk
index 73e61790602f8dbc30fde0da97a57bcba74651ce..68d70ba093357f799a87ccc3a5121c80f8fa462c 100644 (file)
 # d: show subdirectory tree
 # t: show added targets
 # l: show legacy targets
+# r: show autorebuild messages
 # v: verbose (no .SILENCE for common targets)
 
-ifeq ($(DEBUG),all)
-  build_debug:=dltv
-else
-  build_debug:=$(DEBUG)
+ifeq ($(DUMP),)
+  ifeq ($(DEBUG),all)
+    build_debug:=dltvr
+  else
+    build_debug:=$(DEBUG)
+  endif
 endif
 
 define debug
@@ -26,6 +29,10 @@ define warn
 $$(if $(call debug,$(1),$(2)),$$(warning $(3)))
 endef
 
+define debug_eval
+$$(if $(call debug,$(1),$(2)),$(3))
+endef
+
 define warn_eval
 $(call warn,$(1),$(2),$(3)     $(4))
 $(4)