toplevel: fix release name
[openwrt/openwrt.git] / include / depends.mk
index 07345a3998e6d60b3e1d8d1a20a9830e4fad4e6d..53e5b1e5b2e713169b92a4b9b9c257b5b52df019 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -6,23 +6,43 @@
 #
 # define a dependency on a subtree
 # parameters:
-#      1: directory
+#      1: directories/files
 #      2: directory dependency
 #      3: tempfile for file listings
 #      4: find options
 
-FINDPARAMS := -type f -not -name ".*" -and -not -path "*.svn*" 
+DEP_FINDPARAMS := -x "*/.svn*" -x ".*" -x "*:*" -x "*\!*" -x "* *" -x "*\\\#*" -x "*/.*_check" -x "*/.*.swp"
+
+find_md5=$(SH_FUNC) find $(1) -type f $(patsubst -x,-and -not -path,$(DEP_FINDPARAMS) $(2)) | md5s
+
 define rdep
-  $(foreach file,$(shell find $(1) $(FINDPARAMS) -and -not -path "*:*" $(4)),
-    $(2): $(file)
-    $(file): ;
-  )
+  .PRECIOUS: $(2)
+  .SILENT: $(2)_check
 
-  ifneq ($(shell find $(1) $(FINDPARAMS) $(4) 2>/dev/null | md5s),$(shell cat $(3) 2>/dev/null))
-    $(2): $(3)
-  endif
-  
-  $(3): FORCE
-       @-find $(1) $(FINDPARAMS) $(4) 2>/dev/null | md5s > $$@
+  $(2): $(2)_check
+
+ifneq ($(wildcard $(2)),)
+  $(2)_check::
+       $(if $(3), \
+               $(call find_md5,$(1),$(4)) > $(3).1; \
+               { [ \! -f "$(3)" ] || diff $(3) $(3).1 >/dev/null; } && \
+       ) \
+       { \
+               [ -f "$(2)_check.1" ] && mv "$(2)_check.1"; \
+           $(TOPDIR)/scripts/timestamp.pl $(DEP_FINDPARAMS) $(4) -n $(2) $(1) && { \
+                       $(call debug_eval,$(SUBDIR),r,echo "No need to rebuild $(2)";) \
+                       touch -r "$(2)" "$(2)_check"; \
+               } \
+       } || { \
+               $(call debug_eval,$(SUBDIR),r,echo "Need to rebuild $(2)";) \
+               touch "$(2)_check"; \
+       }
+       $(if $(3), mv $(3).1 $(3))
+else
+  $(2)_check::
+       $(if $(3), rm -f $(3) $(3).1)
+       $(call debug_eval,$(SUBDIR),r,echo "Target $(2) not built")
+endif
 
 endef
+